iptables and NoMachine

Forum / NoMachine for Linux / iptables and NoMachine

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #24853


    I have tried to setup NoMachine access remotely on Ubuntu 18 Bionic Beaver across the LAN with an iptables firewall running without success.

    I am able to connect to the server over LAN without any firewall just fine. But if I setup the following config in iptables, then the NoMachine server becomes unreachable:

    Chain INPUT (policy DROP)

    target     prot opt source               destination

    ACCEPT     udp  —       anywhere

    ACCEPT     tcp  —       anywhere


    Output and forward chain are both empty and set to accept all connections. I was hoping that this configuration would allow LAN connections (both of the machines are on 192.168.0.x) but not external connections.


    I am also using SSL if this is significant with a cert file generated as detailed here: https://www.nomachine.com/AR10M00866


    Any advice would be much appreciated! Thanks.


    NoMachine Free 6.8.1 on both server and client machines.

    Server running Ubuntu 18.04 LTS on a Virtual Display. Client running Windows 10.


    Hello OES1,
    NoMachine processes are connecting to each other by the localhost.
    Please add also an exception for that. It could look like that:
    iptables -A INPUT -p tcp -s localhost -j ACCEPT


    Hi Haven,


    Thanks this worked perfectly! Resolved


Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.