Issues connecting to Manjaro KDE Plasma

Forum / NoMachine for Linux / Issues connecting to Manjaro KDE Plasma

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #40395

    I’m having some issues with using NoMachine in connecting to some computers. I can get one computer to connect to one machine, only for that other machine being unable to connect to the other. I’ve tried to debug this issue but nothing seems to indicate why in the logs because all it’s shows is; Connection established from <ip> followed by Disconnect from <ip>.

    Computer B can connect to Computer A, but Computer A can’t connect to Computer B, it’ll show the popup balloon that I’ve connected on Computer B, and immediately followed by disconnect message. There’s no delay with disconnect, it’s just instantly over local network. There’s literally nothing blocking the connection, both computers have same configurations.

    Computer A is a desktop machine, and Computer B is a laptop. Both are running Manjaro Linux, the desktop is running Cinnamon while the laptop is running KDE Plasma, Firewalls are not blocking or configured, in fact even in my router settings all machines are able to see each other and share files just fine and can even connect to each other over SSH. I’ve also tested connection from an Android device to my laptop and seems to manage connecting just fine.

    In addition to all of that, it seems NoMachine also seems incapable of reaching my computers over the Internet despite having my public IP and correct port numbers. Automatic port forwarding is enabled for each device without needing to manually open a port.

    I’ve also been trying to configure NoMachine to connect using RSA Keys but for some reason that’s not working as intended even when the file has been specifically selected for them to use.


    Very strange. We will need logs from Computer A/B, to understand what is happening. Please read the instructions here and send them to forum[at]nomachine[dot]com. Thanks!


    Server side seem ok. Does the session window close as soon as you connect? It could be a crash on the Player side, which would explain why there is not enough information from the Player .

    Can you check for segfaults on the Player side? This article explains how to look for core files.


    Ran GDB with it and just few things to note first off.

    warning: Can't open file /memfd:/.glXXXXXX (deleted) 
    during file-backed mapping note processing
    warning: Can't open file /memfd:/.nvidia_drv.XXXXXX (deleted) 
    during file-backed mapping note processing

    Not sure why it would be trying to access something that can’t be found, but this there is a non-issue because Nvidia drivers are working correctly. Perhaps an XWayland issue? I am unsure, both computers are running XWayland, Android device can connect to both just fine, and one can access the other except in the opposite. But a SIGSEGV is caught for nxplayer.bin;


    Program terminated with signal SIGSEGV, Segmentation fault.
    #0  0x00007f2dbce4f8c0 in XDisplayString () from /usr/NX/lib/
    [Current thread is 1 (Thread 0x7f2da9bfc6c0 (LWP 2596011))]



    I’ve extracted and included the full core dump file.

    I also have to point out that core files for NoMachine does not go to /usr/NX/etc/ as shown in the help article but instead gets dumped to /tmp/ with file name as core-nxplayer.bin--0000-0000-0000-0000

    • This reply was modified 1 year, 9 months ago by Alkaris. Reason: formatting incorrect

    What you sent us shows that it is this problem here, related to Nvidia drivers:

    and not caused by NoMachine software.

    On the Player computer, please edit option key="Enable hardware accelerated decoding" value="disabled" in player.cfg.


    I applied this change but it still doesn’t work. This doesn’t appear to solve anything. This has to be NoMachine software thing.


    I just started an update on Manjaro.

    Everything completed ok except for nomachine.
    Error while configuring nomachine is what I was presented.

    Does the above “bug” still seem like the issue?

    Hope this helps but unfortunately the GDB process listed above is beyond my abilities.



    Oh! Maybe this will help:

    ==> Leaving fakeroot environment.

    ==> Finished making: nomachine 8.1.2-1 (Mon 03 Oct 2022 07:56:55 PM EDT)

    ==> Cleaning up…


    Checking keyring…

    Checking integrity…

    Loading packages files…

    Checking file conflicts…

    Checking available disk space…

    Installing nomachine (8.1.2-1)…

    Running NX post_install script…

    NX> 700 Starting install at: Mon Oct 03 19:57:00 2022.

    NX> 700 Installing: nxrunner version: 8.1.2.

    NX> 700 Using installation profile: Fedora.

    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.

    NX> 700 Compiling the USB module.

    NX> 700 Installing: nxplayer version: 8.1.2.

    NX> 700 Using installation profile: Fedora.

    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.

    NX> 700 To connect the remote printer to the local desktop,

    NX> 700 the user account must be a member of the CUPS System Group: sys.

    NX> 700 Installing: nxnode version: 8.1.2.

    NX> 700 Using installation profile: Fedora.

    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.

    /usr/NX/scripts/setup/nxnode: line 16126: [: too many arguments

    NX> 700 Creating configuration in: /usr/NX/etc/node.cfg.

    NX> 700 ERROR: Error in CUDA initialization..

    Error while configuring nomachine

    NX> 700 Node install completed with warnings.

    NX> 700 Please review the install log for details.

    NX> 700 Installing: nxserver version: 8.1.2.

    NX> 700 Using installation profile: Fedora.

    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.

    NX> 700 Creating configuration in: /usr/NX/etc/server.cfg.

    NX> 700 Install completed with errors at: Mon Oct 03 19:57:08 2022.

    Error while configuring nomachine

    NX> 700 NoMachine was configured to run the following services:

    NX> 700 NX service on port: 4000

    Running post-transaction hooks…

    Arming ConditionNeedsUpdate…

    Refreshing PackageKit…

    Transaction successfully finished.


    Please see my answer to a similar thread here:

    NoMachine client disconnects right after connection in latest Manjaro

    Before changing the configuration key, you should first quit the NoMachine Player (you can do this by right clicking on the !M icon in the system tray and selecting ‘Quit NoMachine Player’.

    Then re-open the Player and connect again. Sorry for not specifying that earlier.

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.