KDE Wayland disconnects immediately after login

Forum / NoMachine for Linux / KDE Wayland disconnects immediately after login

Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #40297

    Hello, I’m using the latest version of NoMachine free to connect from Windows to my Arch Linux laptop. The desktop environment is KDE Plasma 5.25.5 running on Wayland. About a year ago, I was able to connect to my physical display just fine, but then it started failing and I still weren’t able to resolve it.

    I’m able to login to the remote machine, it even displays the balloon message that a new user has connected, but I can’t see the remote desktop in the client (not even a black image, it is white like it’s loading) and after approx. three seconds, the client gets disconnected. I do have PipeWire installed, including xdg-desktop-portal-kde and I’m able to share my screen in other applications.

    This is what nxserver.log says (I’m using SSH to tunnel port 4000, that’s why its showing ::1 as the remote IP, but if I open the port in the firewall and connect directly, the result is the same):

    4736 4736 2022-09-22 21:21:48 929.686 NXSERVER Starting LS 8.0.168 and services.
    4736 4736 2022-09-22 21:21:48 929.750 NXSERVER System information: ArchLinux, standalone.
    5005 5005 2022-09-22 21:22:12 674.820 NXSERVER Connected from remote machine ‘::1’ using protocol ‘NX’.
    5005 5005 2022-09-22 21:22:18 288.786 NXSERVER User ‘jaburjak’ logged in from ‘::1’ using authentication method NX-private-key.
    4736 4736 2022-09-22 21:22:18 497.329 NXSERVER WARNING! Cannot check WM on display :1 EEXIST
    5005 5005 2022-09-22 21:22:24 968.190 NXSERVER User ‘jaburjak’ from ‘::1’ logged out.
    5005 5005 2022-09-22 21:22:24 968.562 NXSERVER Remote machine ‘::1’ disconnected.
    4736 4736 2022-09-22 21:22:25 426.321 NXSERVER WARNING! Session 2C5C4E9D680C208EBED9889E3B31D45D crashed on display 1.

    This is what nxerror.log says:

    Info: Handler started with pid 5005 on Thu Sep 22 21:22:12 2022.
    Info: Handling connection from ::1 port 56870 on Thu Sep 22 21:22:12 2022.
    unable to link authority file /usr/NX/var/tmp/nx, use /usr/NX/var/tmp/nx-n
    Authorization required, but no authorization protocol specified
    Authorization required, but no authorization protocol specified
    4736 5044 2022-09-22 21:22:18 497.170 HostWmRunningHelper: WARNING! Failed to open display ‘:1’.
    Info: Connection from ::1 port 56870 closed on Thu Sep 22 21:22:18 2022.
    Info: Handler with pid 5005 terminated on Thu Sep 22 21:22:18 2022.

    I tried rebooting the remote machine and connecting before logging in, in this case, I can see the login screen (SDDM) in the NoMachine client, but after I log in, the client gets stuck on the login screen and does not show me the desktop session.

    I tried connecting with WaylandModes compositor,drm and WaylandModes drm,compositor, to no avail. If I run nxserver –eglcapture yes, I get an error saying NoMachine can’t find any display manager script.

    If anyone could help me to get NoMachine working again, I would really appreciate it. Thanks!


    Hi, if you are running Wayland in a VM, try the tips here:

    Connecting to a Wayland-based desktop running in a Linux virtual machine

    You could also consider using X.org instead of Wayland like this user https://forums.nomachine.com/topic/connecting-arch-desktop-to-arch-laptop-got-error-104#post-39945


    Thank you, I’m running Wayland on a physical computer and trying to connect to the physical display. Logging in to X.org works fine, but I would prefer Wayland, if some future version of NoMachine will support it.


    I would prefer Wayland, if some future version of NoMachine will support it.

    NoMachine already supports Wayland 🙂 It has done since version 6. But given there are some limitations with desktops on Wayland in general, this will affect the remote desktop experience as well.

    Please see here:

    Notes for connections to Linux physical desktops running Wayland

    Can you send us the logs of the Ubuntu server? Please see the following document for instructions and submit them here or send to forum[at]nomachine[dot]com, making sure to use the topic’s title as the subject of your email. Thanks!


Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.