Keyboard map broken

Forum / NoMachine for Mac / Keyboard map broken

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #36283


    I connect from a Mac to a Linux server.   I have always had problems with the keyboard on the server side, so today I decided to fix it. What a mistake. I followed advice somewhere, and used my mac’s xquartz to get a keyboard map from a local xterm (using xmodmap -pke > xmodmap_ok.txt).

    I uploaded that to my server and ran that there. Now the keyboard on the server side is completely borked – there is no relationship between any key I type and the keystroke I get. I tried to remove all the settings in .nx on client and server side, but that hasn’t fixed. I have no way of logging and typing anything sensible.

    I still have ssh access direct to the server, so I can run something to fix it server-side (where I do not have root).

    Any suggestions?

    Thanks in advance,





    Yes, well, it turned out that by using the GUI I could choose add a new keyboard, delete the old one, and then add the old one back in, and now it’s all working fine. However, in this instance, I find I have nearly all the right keys if I *don’t* use the mac option and just use the GB keyboard. However, it’s not recognising a #, which works fine everywhere else …


    Your second answer came before I could write my answer which was was that I think xmodmap doesn’t change anything permanently, and that a restart or log out of the server would probably have fixed things.

    But you say your # key isn’t working? Are all the other keys working correctly? What mac version is it? What Linux distro and desktop environment is it? You say your local keyboard on the Mac is GB. Have I understood correctly?


    Thanks …

    (I tried logging out of the server, etc, but nothing helped except adding and deleting keyboards. I too had expected xmodmap not to have caused persistent problems).

    I am using a standard apple usb keyboard  set to GB (to a Mac mini running Catalina). With this keyboard I have to type <alt> 3  to get a # key. However, when I type that in a NoMachine terminal it drops into some interpreter with (arg: 3) as the prompt … NoMachine is running on a Linux server running Centos 7.






    Hi Bryan,

    just to be sure, have you tried to use the Right Alt key?


    (right alt) 3 gives me a £; (left alt) 3 gives me the (arg 3) prompt.  (Why would they be different?)

    (thanks for staying with me)


    Please execute the following in a terminal on the server side:

    setxkbmap -layout gb -variant mac

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.