Kubuntu 13.10 – USB Devices Not Available

Forum / NoMachine for Linux / Kubuntu 13.10 – USB Devices Not Available

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #932

    I am testing USB redirection using NoMachine 4.0.366. Server running on fresh Install of Kubuntu 13.10. I am using 4.0366 client on Kubuntu 13.04. When trying to connect USB device, there are no devices  available. With the same setup exception of Server running on fresh Kubuntu 13.04 everything works. I cant figure out if it is a USB permission problem or an incompatibility with 13.10 USB subsystem.  Any ideas would be greatly appreciated.


    Hi, we have just published an article which will help you with this. Can you follow the instructions there and let us know how you get on?



    This does appear to be the problem. When I follow the article instruction to build the module I get the error posted below.


    make -C /lib/modules/3.11.0-13-generic/build M=

    make[1]: Entering directory `/usr/src/linux-headers-3.11.0-13-generic’

    make[2]: *** No rule to make target /usr/src/linux-headers-3.11.0-13-generic/arch/x86/syscalls/syscall_32.tbl', needed byarch/x86/syscalls/../include/generated/uapi/asm/unistd_32.h’.  Stop.

    make[1]: *** [archheaders] Error 2

    make[1]: Leaving directory `/usr/src/linux-headers-3.11.0-13-generic’

    make: *** [all] Error 2


    Hi plop38746,

    “When I follow the article instruction to build the module I get the error posted below.”

    please do not use ‘sudo make’ because sudo drops the PWD environment variable and causes compilation problems. We have just updated https://www.nomachine.com/AR12J00658 to state it more clearly.

    Additionally we found that there is a compilation error (the fix will be shipped with the new packages that we will release soon).

    You can fix the problem manually:

    IMPORTANT: Let’s assume that NoMachine is installed in /usr/NX.

    1. Navigate to /usr/NX/share/src/nxusb

    2. Edit ‘vhub.h’ file in your favourite text editor.
    If you’re using vi or vim you can skip directly to the line in question:

    $ vim vhub.h +60

    3. Edit the 60th line that currently is:


    to have:

    enum { VHUB_NUM_PORTS = 15 };

    4. Save the changes in file (:wq in vim).

    5. You are now ready to compile the module.

    6. Be sure that you run ‘make’ as non-privileged user:

    $ make

    If the build fails due to permission problems, run the following command:

    $ sudo rm -rf /usr/NX/share/src/nxusb/include/linux

    And then retry:

    $ make

    If there are still problems with permissions, run the compilation as root. Use ‘su’ and then run the ‘make’ command.


    That worked perfectly. Thank you so much!!

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.