Local cursor for remote connections to Mac

Forum / NoMachine for Mac / Local cursor for remote connections to Mac

Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
  • #33328

    I swear this was OK the other day (was doing work in Logic Pro X and it would have driven me mental).. So I believe something has changed, and I can’t seem to change it back..

    When connecting to my MacBook Pro through NoMachine I configure it to scale the remote resolution and display full screen, using SwitchResX I configure the MacBook to be 3440 x 1440 (it works fine it just gets framed on the native 2880 x 1800 display of the MacBook), and I connect from a Windows machine which has a wide screen monitor which is native 3440 x 1440.

    Effectively I get full native resolution of my Windows monitor for the full screen remote session in NoMachine.

    As stated this was working just perfectly, however now the local pointer is a massive hand which floats over the remote pointer.

    I found a few forum articles about the local/remote pointer but nothing that helps with this, I don’t mind the two pointers (better if I could just turn the local one off), but it would be nice if the local one was just an arrow like the remote one and the same size, if it must be a hand – also the same size as the arrow, not huge.

    The massive hand only appears when you’re actually working with the remote desktop, if you use the page curl to get into NoMachine settings it goes away, it’s only there when interacting on the remote desktop and you see the local and remote mouse pointers (almost) in sync.

    I have attached some screenshots to illustrate – ignore the hand’s shadow, I was moving it so you could see the hand and the arrow and somehow the phone camera created a ghost hand, the others put the size of the hand into perspective next to normal screen text and on top of the remote arrow.

    Any insight into this would be greatly appreciated.

    Both local and remote versions were updated to see if that fixed anything so currently running NoMachine (Windows 7.4.1, Mac 6.14.1), OS are Windows 10 Pro (latest feature release), Mac OS X 10.12.6, the Mac is not running headless (it’s a MacBook Pro) as with some pointer related issues already mentioned in the forum.


    I have no idea why this changed again.. At least I know I’m not going crazy..

    This remote cursor is now only a single remote normal size arrow! (happy days! for now..)

    Screenshots attached, one not moving, other circling the mouse and thus the repeats and ghost pointer, and comparison Finder shot.

    I did have some issues with my Windows machine and network interface – but I would think that totally un-related to NoMachine (it did include several restarts of Windows – the MacBook has not been restarted since my original post).

    If anyone can shed some light on this in case it reverts to having the “huge hand pointer” as well as the remote arrow – it would be nice to know why it happens and how to stop it! 🙂


    Hi Nyquist,

    we can’t reproduce this issue in our labs and we didn’t receive similar reports. Should it happen again, please let us know, possibly with the steps to reproduce.


    It happened again – only this time it was a huge cursor not hand over the small/normal cursor.

    If anyone else happens across this it turns out it may be very simple.. I was running OBS Studio on the MacBook Pro before I remote connected with NoMachine.

    After connecting and getting the huge cursor, if I quit OBS everything goes back to normal – just one small/normal cursor!

    If I re-launch OBS (while remotely connected with NoMachine and the full screen 3440×1440 as described above), I get a secondary cursor but they are both the same small/normal size.

    Another couple of screen shots attached – 1st single cursor (OBS not open), 2nd two cursors (OBS re-launched after NoMachine connection – I was moving the mouse as they don’t track exactly the same but very close).

    So it’s workable if OBS must be running for any reason – you just need to quit and re-launch after the NoMachine session is established.

    I hope this is useful if anyone else every comes across this – easy once you know the solution – very frustrating when you don’t!


    Unfortunately we still can’t reproduce it in our labs the way you describe and with OBS. Is there any other detail that can be useful for us to reproduce? Any specific action that triggers the issue? For example, do you connect to the MacBook when the lid is closed?


    There are a few utilities running in the background which aren’t native Apple, but you wouldn’t think these have any effect – Dropbox, ExpanDrive, Paragon NTFS for Mac, Oracle Java.

    Then there are the non-Apple apps which DO contribute to the remote session and how it behaves – NoMachine, SwitchResX, Amphetamine (not previously mentioned but doubtful this is a contributor), and supposedly OBS Studio.

    The process I go through is as follows:

    • MacBook is at resolution typically used for the notebook display – 1920 x 1200 – lid is open ready for normal use, OBS is running, and a few Chrome windows
    • Connect using NoMachine (it’s configured to use custom resolution 3440 x 1440 but I could never get this to work in conjunction with SwitchResX despite various configuration so you get 2048 x 1280(!?!) stretched to fit full screen)

    At this stage the huge hand/pointer is present – looks ever bigger because of the stretched resolution.

    • Use SwitchResX custom saved configuration to switch to 3440 x 1440

    Huge hand/pointer also resizes and is now in correct aspect ratio but still huge.

    • Set Amphetamine to start ‘indefinitely’ (only used to stop the MacBook sleeping if/when you close the lid, none of the other features are touched)
    • Close the lid if desired – typically I prefer this for desktop space and NOT to look at the windowed cinemascope like effect on the notebooks screen
    • Quit OBS (and re-launch only if necessary)

    It’s only at this last stage when I quit OBS the huge hand/pointer disappears immediately and left with only one normal size pointer. If I re-open it a second pointer turns up again but normal sized as mentioned.

    Interestingly, leaving OBS open after quitting and re-launching, then if I quit the established NoMachine remote session on Windows but at some point reconnect a remote session (having not touched OBS) I get the two normal size pointers. To get the huge pointer back I need to quit NoMachine remote connection AND quit and re-launch OBS on the MacBook, then connect remote session to get the huge pointer – I’m not sure what that means but it seemed significant – it’s like OBS (or something) “remembers” it was quit and re-launched inside a remote session until it’s launched from scratch on the notebook without an active remote connection.

    I can’t think of anything else that’s different from a typical install, only other running application when I connect is (typically) Google Chrome with a few windows and tabs open and that’s it! Other background stuff is all native Apple – Time Machine (not actively running), Siri, etc.

    If I happen across anything else I will post an update. It does seem to be very reliably repeatable on my current OS X system (though I have also not seen the huge hand again since my original post, it’s been a huge pointer each time).


    We are reproducing something similar to the “huge cursor” issue in our labs and we can send you a possible fix as soon as it is ready, if you are willing to give it a try. In the meanwhile, can you confirm that the cursor goes back to the normal size as soon as you force it to change its shape (for example by hovering on a window’s corner to change it to the ‘resize’ shape)?

    We can’t reproduce the issue with the “double cursor” (local and remote cursor both visible). Does leaving the lid open have any effect on this problem?


    I would certainly be willing to trial a fix on my machine.

    The cursor on the MacBook is normal size and changes depending on screen region, the “local cursor” seen on NoMachine client remains the huge pointer and never changes shape.

    Apologies for the dodgy screen shots taken on my phone – see attached, the edit bar (edit.jpg) + select hand (hand.jpg) + resize arrows (resize.jpg) which can be seen “behind” the huge cursor are what’s seen on the MacBook screen at normal size (makes no difference with lid open or closed), the huge pointer is always on top of this seen only on the NoMachine client screen.

    If I close and re-open OBS the “local cursor” still remains the same (though now normal size) pointer shape no matter what screen region (hand-after.close+re-open.OBS.jpg) but the MacBook cursor still changes as expected depending on screen region (again makes no difference with lid open or closed).

    Hope that all makes sense.


    I’m having the same cursor problem on version 7.6.2. I’m using a MacBook Air set locally at 1680 x 1050 resolution. The remote system is running Windows 10 at a resolution of 1920 x 1080 and I use fullscreen but no scaling at either end. The remote system is using a virtual display. The remote cursor is set to not be displayed. When I first connect, the local cursor is at its normal size, but sometimes when I move the cursor, the local cursor becomes huge, identically to the screen shots above. When that happens, the cursor motion slows to a crawl and accurate clicking becomes very difficult.


    From further descriptions provided by the both of you, it looks like the issue that you are reproducing is not the same we reproduced in our labs (that anyway only affects the initial cursor size, as changing the cursor shape would fix it immediately). So please let us know:

    – What happens when you drag the cursor (move the mouse while the left button is pressed)? No matter where you do that, it can be on the desktop. Do you still see two cursors, the huge one and the normal one?

    – What happens if you enable the ‘Show remote cursor pointer’ option in the Input menu? Do you still see the same two cursors?

    – Could you record a video of your screen showing the problem?


    Screen capture attached – it’s all stretched as I didn’t change the resolution after connecting, but it’s exactly the same no matter what resolution you set the MacBook too, I tried several and that makes no difference to the pointer effect..

    When I drag the cursor nothing changes, you still see both pointers.

    With ‘Show remote cursor pointer‘ option enabled I see three pointers – two huge ones and one normal one – when I drag the cursor with this option it goes back to two pointers (one huge and one normal), when I stop dragging it becomes three pointers again (two huge ones and one normal).


    Sorry for the delay, still not able to reproduce it here. Anyway your last findings gave some food for thoughts, but we would need a confirmation. Please use the ‘Take a screenshot’ button in the Connection panel of the session menu. Take a screenshot with ‘Show remote cursor pointer’ off and again with this option turned on, and see how many cursors are shown in the image and their size. Then, if you are available to do so, you can use session recording to record the NoMachine session (Recording panel of the session menu). Again, see how many cursors and size. You can share the screenshots and the recording file here, if you wish.

    Thank you in advance 🙂


    I took the screen shots as you suggested using the ‘Take a screenshot’ button and attached them labelled accordingly.

    With the Show Remote Cursor option OFF there only appears to be a hand, this is the correct remote cursor as seen directly on the MacBook screen (it’s Help Desk software in Chrome and should be a hand when floating over tickets). However on my Windows remote session screen the huge cursor is still there, it just doesn’t show in the screen shot using that button.

    With the Show Remote Cursor option ON another huge pointer appears in the screen shot (over the top of the hand) using that ‘Take a screenshot’ button.

    The recorded session is also attached, the motion seen at the beginning is moving the cursor with Show Remote Cursor OFF, the pause seen in the middle is me going into the menu and turning that option ON then the cursor comes back into view and moves around a little more.

    The recording doesn’t show any difference – I did try this method originally, but since it didn’t reflect what I actually see on screen I ended up using other 3rd party screen capture software on my Windows machine to capture the previously submitted file – this was the only way I could get a recording of what I actually see.


    I received an upload error – that the .nxr screen recording file type is not permitted for security reasons – have re-encoded as .mp4 package and attached.


    Thank you for the files, they help to narrow possible causes down. Would you be willing now to install a debug package and collect some logs for us?

Viewing 15 posts - 1 through 15 (of 29 total)

This topic was marked as solved, you can't post.