"Lock physical screen" doesn’t blank physical display

Forum / NoMachine for Linux / "Lock physical screen" doesn’t blank physical display

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #14000

    Good day,

    Long time user of NoMachine. Use it on Ubuntu and Fedora mostly.

    One major issue I’m observing on my Fedora24 system is that when I connect remotely to the physical display, despite the “lock physical screen” checkbox being set in the GUI, the system doesn’t blank physical display while the user is connected.

    So, if the user leaves their monitors on, anyone at that physical location can see /exactly/ what that person is doing. (highly undesired)

    The configuration states, and I can confirm the setting has been set in server.cfg (and even following system reboot…)
    # cat /usr/NX/etc/server.cfg | grep -B13 Screen
    # Enable or disable locking the physical screen of this machine when
    # somebody is connected (screen blanking).
    # 1: Enabled. The physical screen of this machine is blanked and the
    # local user cannot interact with the desktop while somebody is
    # connected.
    # 0: Disabled. The physical desktop of this machine is not locked
    # when somebody is connected. All operations made from the remote
    # user are visible to the local user. The local user can interact
    # with the desktop. This is the default.
    #EnableScreenLock 0
    EnableScreenLock 1

    Clearly, it is enabled 🙂 — and this agrees with the GUI setting.

    What gives? How to debug.



    to investigate further we would need you to reproduce the problem, collect logs and send them to forum[at]nomachine[dot]com.
    Instructions about debug and collecting logs you can find here: https://www.nomachine.com/DT07M00098.


    gathered logs and send to the requested email


    it looks like you are connecting to Fedora with an old version of NoMachine (5.0.53). Could you try to upgrade  to the current version (5.2.11) and see if the result is different? If this is not the case, I would like you to answer two questions:
    1. Can you tell if the input (mouse and keyboard) is locked on the server side? It should not be responsive while blanking is enabled.
    2. Would you be willing to reproduce the problem with a debug package that would allow us to investigate the problem? If so, please contact us via email: forum[at]nomachine[dot]com.


    Confirmed, even on latest versions (Linux -> Linux), both running 5.2.11.

    1. CONFIRMED: that the system /is/ in fact still locked (although it of course gives away exactly what the user is doing remotely to anyone who turns on the monitors at the physical workstation)

    2. YES, i can meet to reproduce problem. Will send mail.


    Hi, can you just confirm that it is Fedora? Is that 32bit or 64?

    Also, just to be sure, are you using any brightness changing apps like f.lux on the server side?


    Great questions.

    Indeed, 64-bit.

    `$ uname -a
    Linux ${USER}-lnx-1 4.9.13-101.fc24.x86_64 #1 SMP Tue Mar 7 23:48:32 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

    Wow flux, good point. I had installed this YEARS ago, and it’s just worked forevermore.


    $ ps wauxxx | grep xflux
    mcallag+  5134  0.0  0.0  31952   100 tty2     S+   Mar13   6:53 /home/${USER}/bin/xflux -l 43.48 -g -80.54
    mcallag+ 11515  0.0  0.0 118492   932 pts/2    S+   14:49   0:00 grep –color=auto xflux
    $ file /home/${USER}/bin/xflux
    /home/${USER}/bin/xflux: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.18, BuildID[sha1]=546afa8b6a16c78da97eef00b561adbfed80721f, not stripped


    Of immediate interest … it’s possible that it isn’t playing nicely with flux in general.  I killed the process, and retried.

    • Report = screens remain black/bank now! (it helped!)


    Remaining Issue:

    •  monitors at the physical location STILL unfortunately shows the user’s mouse/cursor moving around while they work 🙁

    (awkward/annoying still, but at least privacy is retained)


    Triple confirmed the xflux incompatibility

    – when flux is running, NoMachine’s “blank screen” really screwed up (flickers)

    – when flux is disabled, the flicker is no longer a problem


    – even with flux disabled, there’s still a bit of an awkward situation where the mouse pointer/cursor is STILL visible on the black screen, and it moves around as the remote user works – people physically on premise would be surprised to see a mouse pointer moving around on a black screen 😮


    Should we mark this as “fixed”, and create a new thread for the floating mouse cursor issue?


    The floating mouse cursor can happen with certain Linux desktop environments: https://www.nomachine.com/AR07M00851

    So there’s no need to start a new thread 😉

Viewing 10 posts - 1 through 10 (of 10 total)

This topic was marked as solved, you can't post.