Logs filling up the Mac Console

Forum / NoMachine for Mac / Logs filling up the Mac Console


Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #4952

    I just updated to the latest free version of NoMachine for OS X (4.3.24 I think) and was mightily disappointed to see that the bug which pours a continuous torrent of repeated messages (as below) at a rate of 21 per second, every single second, into the Console Log, has not been fixed.  I would have thought this was a serious issue.  I would also have thought it would have been a trivial fix.

    “CGSServiceForDisplayNumber: Invalid Display: 0x41dc9d03”

    Seriously, guys, this is a major snafu.  The Console App is an important diagnostic tool, and NoMachine is essentially bombarding it with a Denial-Of-Service attack.  NoMachine is otherwise a great App, but you’re killing me with the Console crap!

    My server is a headless Mac Mini running OS X 10.9.5 and the client is a RMBP running OS X 10.9.5.  NoMachine is fully up-to-date on both machines.


    Update:  I just installed OS X Yosemite on both my Mac Mini (Server) and RMBP (Client).  The replicated Server screen now has a 4:3 aspect ratio whereas previously it used to fill the 16:9 RMBP screen in correct proportion with no stretching.  I have no idea what determines this behaviour.  I didn’t do anything previously to produce the 16:9 screen, and have done nothing this time to produce the 4:3 screen.  I don’t (and didn’t) see any options in either NoMachine or OS X that would affect this.

    Now the torrent of messages no longer appear in the Console Log!  Is this because I am now running Yosemite, or is it because my screen aspect ratio is now 4:3?


    Hi BitPerfectRichard,

    we finally managed to reproduce the problem with Console Log and the fix will be included in the upcoming software update.

    The issue was related to the “Resize remote screen” feature and disabling it would have worked as a workaround. The reason why you don’t reproduce it with the just released Yosemite is that remote resize is not yet fully supported there and we are working on it. This should also explain why you don’t get the expected resolution.


    Thanks guys.  Happy to hear that 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.