Lost display Windows 11

Forum / NoMachine for Windows / Lost display Windows 11

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #48742
    pxr5164
    Participant

    Hi all,

    Real noob here. I’ve just started using NoMachine after years with [removed]. I have a headless mini PC running Win11 and installed NoMachine on it. I then installed it on to to 2 laptops (both Win11) to access this Mini PC. All was working great until I tried to change the resolution from one of the laptops. Now whatever I set the display to (client 1), I only have a black screen and mouse – I can see the mouse moving on the MiniPC when I put a monitor on it. The other laptop (client2) I haven’t touched and that is OK. I’ve tried every display setting I can but nothing is showing on this laptop – I even uninstalled NoMachine on the laptop and reinstalled it, but it’s still the same. Please help 🙂

    #48749
    Britgirl
    Keymaster

    Hi, and welcome to the forums 🙂

    you can try to disable NoMachine HW decoding on the “problematic” laptop. To do that, follow the instructions here: https://kb.nomachine.com/AR07U01202, choosing to completely disable (point 3). I’ll write them here to keep the info in this thread.

    – Exit the Player (right click the !M icon in the system tray and click “Exit the player”)
    – Locate the player.cfg, on Windows the path is typically %USERPROFILE%\.nx\config\player.cfg.
    – Open in notepad (rename the original cfg to not lose it) and find the “Enable hardware accelerated decoding” key and set it to ‘Disabled’ like this <option key="Enable hardware accelerated decoding" value="disabled" />
    – Save and close.
    – Re-open NoMachine.
    – Try and connect again.
    – What happens? If you get the same problem, then we would need to see the logs from both client and server sides.

    For the server side, so the MiniPC side, please follow the instructions here for Windows, https://kb.nomachine.com/DT07S00243?s#2. Instead, for logs from the affected laptop, tick the box “Don’t delete log files on exit checkbox” in Player settings: Open the main window from the UI -> Settings -> Player -> Security panel, before starting the session to reproduce the problem. Then find the .nx folder in your user’s home, and zip it up. The .nx folder is hidden. To find it, write the following in the address bar or the file browser: %USERPROFILE%\.nx. As an alternative, you may navigate through the computer folders till the user’s home and insert .nx in the navigation toolbar to reach this hidden folder. The path can be similar to: C:/Users/nomachine/.nx.

    Send everything to forum[at]nomachine[dot]com.

    #48750
    pxr5164
    Participant

    Thank you so much. I carried out the steps in the first part of your solution and that worked. For cleanliness I uninstalled and removed the .nx folder and reinstalled. I won’t touch the resolution settings again (shame though). Apologies too for the mention of the other program.

    #48752
    Britgirl
    Keymaster

    ahhh shame you removed the .nx folder, this could have been useful to understand why this particular Win11 is affected. If it happens again, grab the .nx folder first before doing a reinstall, then come to the forums 🙂

    #48755
    pxr5164
    Participant

    ^ OK, will do 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.