Mac Player not exiting

Forum / NoMachine for Mac / Mac Player not exiting

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #16044

    I’m running basic (free) NoMachine on a Mac from a Bash script that sets up an SSH tunnel, then launches NoMachine and waits for it to exit (open -W -a NoMachine <connection-file-path>), then kills the ssh process and exits. With this method, I just run the script and no intermediate typing or clicking is required. The remote system is a Windows laptop (details below).

    The script itself works fine; the issue is that when the NoMachine connection is terminated with Ctrl+Alt+T and the Exit the player button is clicked, the connection seems to terminate and the window closes, but the player doesn’t actually exit – it stays visible in the Dock and requires a manual Quit. At that point, the Bash script resumes, kills the SSH tunnel process, and exits.

    I have NoMachine 5.3.12 on both the Mac and Windows machines, and don’t have this issue with the player on Windows when connecting to other Windows systems; it exits completely when the Exit… button is clicked. The Mac I’m using is running OS X 10.10.5 (Yosemite) and I’m connecting over the internet to a Windows 7 Enterprise laptop (physical display) running the NoMachine 5.3.12 server.

    Even if I run the ssh command and launch NoMachine manually, the player still doesn’t exit when the Exit… button is clicked.

    Is this a bug? A feature?




    Hi. In order to be compliant with OS guidelines the player works in a slightly different way on macOS: there are one or more player processes running connections, and a bundle acting as an HUB for all those connections. When you want to close NoMachine on macOS you not only need to close the player process, but also the bundle. The command “open -W -a …” will return the control to the caller only when the process ‘nxdock’ will terminate.


    Understood; thanks. Perhaps something could be devised with Automator if there’s a way for a script to detect the terminate event. (Or I can just continue to type Cmd-Q, but I was hoping to avoid that.)

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.