MacOS start NX server at boot time?

Forum / NoMachine for Mac / MacOS start NX server at boot time?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #24241

    It appears that the NX server is started (MacOS) when a user logs in. Is it possible to start it when the computer boots, so that in the event of a power failure and restart, etc, that it would start automatically?


    What version of macOS are you using?

    Was it installed through command line? If not and if mac os is not “Catalina” then we will need some logs.
    Article on how to collect logs: (“How to gather debug logs for support requests”)

    Please enable them and reproduce issue (restart whole os that it will be on login window, try to connect, then log in and connect correctly again.

    Gather logs after that.

    After gathering logs, please send them to forum[at]nomachine[dot]com using the title of that forum’s thread as the mail’s subject.


    Could you also show ouput of # /etc/NX/nxserver –status when it is on login window?



    macOS 10.14.6 Mojave

    Was not installed through the command line.

    Logs have been emailed.

    /etc/NX/nxserver –status
    NX> 111 New connections to NoMachine server are enabled.
    NX> 162 Enabled service: nxserver.
    NX> 162 Enabled service: nxnode.
    NX> 162 Enabled service: nxd.

    In this instance, the client appeared to be connecting then got an error:  “Attempting to reconnect to ….. Error was: connection timed out. ”




    Logs don’t include the full problem (looks like could be enabled little to late), could you check next time on login window if:
    – nxserver –daemon is running (for example with ps -ef | grep nx)
    – then gather his pid and check if it is listening on localhost (command sudo lsof -p <pid of nxserver --daemon> | grep -a LISTEN)

    Also new set of logs with these informations would be needed, at the moment it looks like daemon is not running or is not accepting any connections.


    It does appear that the daemon is running

    ps -ef | grep -i nx
    499    81     1   0  8:22AM ??         0:01.02 /Applications/ –daemon
    0   259     1   0  8:22AM ??         0:00.59 /Applications/ –localsession
    499   283    81   0  8:22AM ??         0:00.01 /Applications/
    0   337   332   0  8:22AM ttys000    0:00.00 grep -i nx

    and listening

     lsof -p 81 | grep -a LISTEN
    nxserver.  81   nx    8u  IPv4 0xd9cf5c8cb9495dbb      0t0     TCP localhost:21745 (LISTEN)

    and a nmap command from another computer shows that it is listening on port 4000/tcp. And a connection from that other computer while at the login screen worked, and I was able to log in.

    But, the behavior is inconsistent.  I rebooted and tried again and the remote client showed <No available sessions on this server>. The ps and lsof command output was similar to that above. Log files for that instance have been emailed.


    Looks like it is a problem with the detection of the correct desktop owner on your machine, as there is no current workaround for such issue, we could prepare and send you patched package. Are you interested in receiving and testing it?


    Yes, I can do that.


    Update: the user has confirmed that the latest version (6.9.2) is working without any issues.

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.