Manual command entry needed

Forum / NoMachine for ARM / Manual command entry needed

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #42881
    dexterfishborne
    Participant

    Hi,

    Nice software. Need it as [removed] and [removed] don’t run on my headless manjaro aarch64 (pine64-lts).

    It works, but I need to enter:

    $ /usr/NX/bin/nxserver –restart

    manually, after each reboot. Or I can’t connect.

    My failed attempts at automation:

    • Xfce4 on boot script
    • systemd service on reboot
    • cron job on reboot

    Anyone have a bone to throw? Happy to supply further info on request.

    #42891
    Britgirl
    Participant

    Did you install package from our website or from the aur repository? We tried the packages from the aur repo on the fly and they indeed behave in the same way as what you are experiencing. Maybe tell the guys who handle the repo at https://aur.archlinux.org/packages/nomachine?

    You can check what you have set by running:

    sudo /etc/NX/nxserver --startmode

    If the output is similar to this, then it’s the packages which are messed up:

    NX> 807 Service NoMachine status is: Automatic
    NX> 807 Service NXD status is: Manual

    To change it run sudo /etc/NX/nxserver --startmode nxd automatic

    #42892
    dexterfishborne
    Participant

    Thanks Britgirl!

    Indeed, I left a comment at

    https://aur.archlinux.org/packages/nomachine

    (I now notice I was not the first there to do so).

    Brill, I’ll mark as solved.

     

     

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.