Mavericks not supported?

Forum / NoMachine for Mac / Mavericks not supported?

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #218

    I had a working solution under OSX 10.8, connecting to a windows 7 machine. Upgraded op Maverick yesterday, and since then not being able to connect anymore. Reinstalled client 4.0.352 just to be sure, but to no avail. No firewalls etc, just the upgrade to Maverick (which has been available for developers for months!)

    A serious quick fix would be highly appreciated.


    Definitely not. We tried the 10.9 distributed to developers and it worked fine (except for a USB issue that pushed back the release by one week). It was a clean install, though. We are trying to see if we can get the same problem on a upgraded machine. Fortunately it should not be difficult to reproduce, since this is the second post reporting this.


    MY Mavericks installation ended up in a continuously repeated reboot loop. After I booted to Safe Mode I could see the crash info
    that hinted about a nomachine product. And by removing the Nomachine app Mavericks would boot up correctly. This took me several hours to debug and resolve. I can live without that app for now. Probably in some future the fine folks at Nomachine will add support for Mavericks as well.

    I can post the debug info if that is of help to understand the problem.

    • This reply was modified 10 years, 7 months ago by mobimation.
    • This reply was modified 10 years, 7 months ago by mobimation.
    • This reply was modified 10 years, 7 months ago by admin.

    I had the same problem. However, you don’t need to completely remove nomachine app. The client works fine. It is the server that gives you kernel panic. You need to remove the following to avoid kernel panic:

    1. nomachine’s kext in folder /System/Library/Extensions
    2. remove *nx* in /Library/LaunchStartItems, /Library/LaunchAgent, /Library/LaunchDaemon

    I don’t remember the files exactly, but you get the idea — just remove it from start up scripts so that the daemon is not started. The client works fine. Of course, if you removed those, you won’t be able to remote into your mac. If you need that, you may have to look deeper into the scripts and plist to pin point the problem.


    There’s no need to remove anything. The problem is the USB drivers which must be disabled. This article explains how to do that: As it says, NoMachine is investigating the cause and a solution will be made available very soon.


    Thanks! As I remember, it was indeed when loading nxusb something in verbose mode that the kernel crashed.

    If you work for nomachine, please let your developers know that we don’t really need usb support, client or daemon. All we need is a desktop so that we can keep working on a doc file or some other code after we get home. By the way, nomachine rocks! I remote into a linux computer, and it is very fast.


    We had same problem here on a mac mini. First only removed the usb related kexts from /Library/Extensions:
    nxusb_helper.kext, nxusb_io1.kext and nxusb_io2.kext.
    Same problem.
    Then removed kexts from /System/Library/Extensions/
    nxaudio.kext, nxfs.kext and nxtun.kext
    And from /Library/LaunchDaemons/

    Then it worked.

    A hint: when starting with command-R, start a terminal from utilities on the menu bar,
    the actual root dir was below /Volumes/Macintosh HD/
    not /


    Path 4,

    You might not need USB support, but there are rather a lot of other customers who do which is why it’s a functionality of the software. If you don’t want the USB feature, you can just disable it.

    When we were deciding what to offer in the free version, we decided to keep the same level of functionality as the Enterprise products. This is the first time that I’ve heard from a user of the free version that they would like it to do less 😉



    We have split this topic into two separate ones because it deals with two different issues.

    You can find them here:

    • This reply was modified 10 years, 7 months ago by Britgirl.
Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as closed, you can't post.