Mouse Action Blocked

Forum / NoMachine for Linux / Mouse Action Blocked

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #15203

    Server Version : 3.5.0.-9 / Ubuntu 12.04 – GNOME

    Client Version : 5.3.9 / Windows 10

    Virtual display


    Hi every1.  I was having a problem running my sikuli based automation program (this problem is speculated to be because of the VM).  Essentially it moves the mouse, but unfortunately the console keeps throwing an error saying the mouse action is being blocked.  I posted about this issue on the Sikuli forums and they told me to check my VM settings concerning mouse behavior.  Which is why I am now here asking for help as it is speculated that the cause of this issue has something to do with the VM itself.  I also tried to use Java’s own ‘robot’ class in their library, and I cannot make any mouse events using that either.


    Error for anyone who is curious ->


    Any suggestions?


    Hello, I tried xdotool directly and it looks working. In a terminal with bash, the command:


    $ while true; do x=$[$RANDOM%256]; y=$[$RANDOM%256]; echo "Moving to ($x, $y)"; xdotool mousemove $x $y; sleep 2 ; xdotool getmouselocation; done


    shows that move succeeded and was not changed nor blocked.

    Can you suggest a simple Sikuli example I could try?


    Please note that 3.5.0 is legacy which is not dealt with in the forums.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.