Mouse click not working

Forum / NoMachine for Linux / Mouse click not working

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #35256


    I am using NoMachine 7.6.2 and Ubuntu 20.04 LTS server with xfce.

    After some time the mouse click (left and right) will stop working. I can still move the mouse but clicks are not registered. I have to reboot the Ubuntu server to make it working again.

    It seems that this issue has been there since v4.x? And I’m surprised it’s still not fixed.


    Xinput results


    Virtual core pointer                          id=2    [master pointer  (3)]

    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]

    ⎜   ↳ Windows pointer                           id=6    [slave  pointer  (2)]

    ⎣ Virtual core keyboard                         id=3    [master keyboard (2)]

    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]

    ↳ Windows keyboard                          id=7    [slave  keyboard (3)]


    HI, This issue is happening for me as well where mouses click and keyboard  strokes aren’t working on remote Linux machine. Also, as I can’t be physically present at server machines to reboot the server, so in this case, what are the options to make to start to work?



    You can ssh to your server to reboot it.

    I noticed that the default setting for remote users enables ‘require permission for remote users to connect’, which needs to be manually disabled if using for unattended servers. I’ve disabled this option (requires a restart of NX server) and it seems OK so far.

    It’s a strange setting as when you first install it or when the server just reboots you’d be able to connect but when you are connected for a while this setting will then kick in.

    Give it a try.


    OK I was optimistic too early. The problem still persists…


    Do you have to reboot the server? Restarting Xfce would be enough.

    I cannot say that is a problem with NoMachine, maybe some stale grab from an application or for Xfce window manager.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.