Mouse control issue

Forum / NoMachine for Windows / Mouse control issue

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #3842

    I use a Windows client connected to a Linux remote desktop and I have a really annoying mouse control issue.  It appears most evidently when I try to play any games over NX, though its in other apps occasionally, as well.  But not as severely.  If I try to use the mouse for any sort of control, be it moving an avatar or changing a camera angle, the view immediately swings to directly up and any attempt to change it merely spins the camera in a circle.

    This is on 4.2.24 on both sides, Windows 7 client and OpenSUSE 13.1 server-side.



    Hello jcdick1

    I’d like to replicate the issue you are describing. Could you tell me which is the game you tried?


    I apologize for it taking so long to get back to this.

    A good example of a game would be “Metro: Last Light” for Linux under the Linux Steam Client.  Any mouse control immediately points the POV to the ground and any further mouse movement just makes it spin.

    This is a Windows 7 x64 with v4.2.26 connecting to a Linux machine, OpenSUSE 13.1 x64 with KDE also running v4.2.26.



    I know that the core developers are working on this (it’s a known problem). A temporary workaround is to connect an additional usb mouse
    and share it to the remote side as a USB device. Nice to know that you play games with NoMachine 😉

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.