Mouse is missing in Windows 8

Forum / NoMachine for Windows / Mouse is missing in Windows 8


Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #2840

    Cursor is invisible during NoMachine session over home LAN via ethernet. No monitors are attached and cursor was visible in with version 4.


    Please be sure that you update to the latest version. This should be always a requirement before starting any investigation. Let us know.


    I’ve done that too, unfortunately I’ve installed version 4.0. Version 4.0 has some weird login problem where the screen turns black after waking from suspend.


    It’s not clear whether you installed 4.2.19? You have to do it manually:

    Additionally, it is not clear what you are running on the server side. A similar problem is reported here: 

    If it is the same problem, I suggest you participate in that topic.

    • This reply was modified 10 years, 2 months ago by Britgirl.

    Now I’m using Version 4.2.21_1, the mouse stays invisible. Is there a way to overwrite whatever current file or library that is used for the mouse cursor, with an older version?



    May I suggest you disable display acceleration on the server? Article shows how to do it.


    Thanks, graywolf, I’ll try that. My only worries, are if my Linux Virtual Machine, will still receive hardware acceleration and if DirectX will still work.


    Hello Daisukiniwa,

    have you tried with display acceleration disabled? About your concerns, if you disable it your server switches to a different method of screen grabbing, while DirectX is still available but you lose the ability of capture DirectX applications in full screen mode.



    I have similar problem: mouse cursor lost on Windows 8.1.

    Server: Linux 3.13.0-26-generic #48-Ubuntu SMP i686 GNU/Linux

    Client: Windows 8.1, NoMachine 4.2.21 – 4.2.23

    Problem was found today, shortly after windows was updated (KB list below).

    Things I’ve tried so far:

    • disable hardware acceleration;
    • change mouse cursor theme;
    • change encoding codec;
    • change client OS to Windows XP SP3;
    • updating NoMachine to 4.2.23

    None of this measures were effective.

    Installed updates (in time stright before problem find out):

    KB2931358 (IE11 update)
    KB2954879 (.NET 4.5 security update)
    KB890830 (definition update)
    KB2953522 (IE11 update)
    KB2957151 (IE11 Flash update)
    KB2931366 (.NET 4.5 security update)
    KB2542054 (VS Express 2010 update)

    • This reply was modified 10 years, 1 month ago by Britgirl.
    • This reply was modified 10 years, 1 month ago by Olloff. Reason: Its a shame but I got lost between those client/server definitions, fixed that

    Version: 4.2.23 both client and server, both Windows 8.1 machines.

    I have this problem as well. It worked initially but somewhere along the way (and there were Windows updates in that interim period) I have lost the mouse pointer. The pointer still works, it is just invisible – for instance if I right click on the desktop I get the context menu. None of the things listed here seem to make a difference, I have also tried both on and off the “Show remote cursor” option in NoMachine. This only happens to a Windows target machine; my Linux machine acting as a server still works fine and shows the pointer.

    Additionally the mouse mapping within the displayed window appears non linear, regardless of acceleration settings. That is to say if I place the mouse cursor immediately outside the NoMachine window, then move the cursor in, the (now invisible) cursor is not in the expected location, but shifted.

    Given what Olloff and I both have seen I imagine this is connected to a Windows update in some way, particularly since mine worked before.


    Hello frob.

    Is it possible that your Windows has no mouse installed, or is the mouse turned off when you use NoMachine to acces it remotely?


    Hey, graywolf now that you mention it, I didn’t have a mouse attached,  it worked after attaching one. Though, I wonder why now because before 4.1 I didn’t even need a keyboard, oh well.


    How can I mark this as solved?


    Please let me know if version 4.2.24 addressed this issue.


    Hi graywolf,

    You are correct, the machine in question did not have a mouse connected to it at the time (it is an HTPC machine, and boots without keyboard/mouse because they are bluetooth and only activate when needed).

    I can tell you that 4.2.25 fixes this…sort of. If I boot with a mouse/keyboard originally connected, then disconnect them, I can then remote in from another machine (although I get an old X-window style cursor instead of a windows one, but no problem).

    Unfortunately if you boot the machine with 4.2.25 installed WITHOUT a keyboard and mouse present, nomachine crashes badly at initialization, and keeps crashing continuously if you acknowledge the dialog box, even after you have re-attached a keyboard and mouse.




    may you send the content of %PROGRAMDATA%\NoMachine\var\log  and %USERPROFILE%\.nx  to issues(at)nomachine(dot)com ?

Viewing 15 posts - 1 through 15 (of 15 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.