Mouse often in wrong place

Forum / NoMachine for Mac / Mouse often in wrong place

Viewing 3 posts - 16 through 18 (of 18 total)
  • Author
    Posts
  • #47799
    WalkerJ
    Participant

    This issue happens to me when I use NoMachine in full screen, which puts it in another desktop “space” on current Mac operating systems. Sometimes switching from the NoMachine desktop space to my primary space and back will trigger it, but not always. If it happens the only way I’ve been able to fix it is to close and reopen NoMachine, but that doesn’t always work.

    Another issue that also happens when using NoMachine full screen is that sometimes the Mac menu bar is still present and overlaps the NoMachine view. This is a problem because the Macos menu bar covers the top of windows and prevents moving the window or something accessing menu options. I don’t know if these two issues are related, but they both happen under the same circumstances for me, so maybe using full screen is a trigger for one or both?

    I attached a screenshot showing the Mac menu bar overlapping the NoMachine window in full screen.

    #47946
    Britgirl
    Keymaster

    Hi, regarding the menu bar issue, we are working on improving the user experience when using NoMachine in fullscreen on macOS, and these improvements are planned for version 9.

    WalkerJ, about the cursor issue, can you do the following when the problem occurs? Enable “Show remote cursor pointer” in the Input menu, and check whether the remote cursor moves or not.

    #47947
    lgerhardt
    Participant

    For me, I don’t see the remote cursor move when the problem occurs. The nice thing is that if I go to the menu and toggle “track remote cursor” off and on it starts working again, which is a great improvement over my previous solution of quitting and reopening.

Viewing 3 posts - 16 through 18 (of 18 total)

You must be logged in to reply to this topic.