Mouse pointer issue

Forum / NoMachine for Linux / Mouse pointer issue

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #20390



    Linux Server

    Ubuntu 12.04 (Linux 3.2.0-67-generic i686 i686 i386 GNU/Linux).

    Xfce 4.8.

    NoMachine Small Business Server 6.3.6.


    Clients (NoMachine Enterprise Client)

    Windows 10

    NoMachine 6.3.6.


    NoMachine 6.3.6.


    I have noticed an issue with the mouse pointer not updating, this happens only when the server is configured for X11 graphics mode. It also only occurs the first time the client app (Windows or MacOS) connects to server and opens a new virtual desktop.

    1. If the player is then closed without closing the Ubuntu session and subsequently the same session is reopened the issue disappears.

    2. If the player is closed by logging out of Ubuntu and closing the current session, on creation of a subsequent new virtual desktop session the issue reappears.

    This issue did not seem to affect the last version of the server/player.

    I have attached a couple of snapshots. You can see the resize not updating when the pointer leaves the window area.

    One further point is that I tried to record the screen using the NoMachine screen recorder (and a recording was generated), but when I tried to play it back in NoMachine it declared the file corrupt (I tried this twice using the Windows player).



    Hi, can you try attaching those images again? If they are too big, you can send them directly to forum[at]nomachine[dot]com. Thanks!


    Ok, I’ll try now thanks!


    Thanks for the report!

    We were able to reproduce problem. Please follow this trouble report: and use the notify me tool to know when a fix is available.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as closed, you can't post.