MX Linux not connecting to Raspberry Pi

Forum / NoMachine for Linux / MX Linux not connecting to Raspberry Pi

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #47149

    I’ve installed NoMachine under MX Linux 21.3, on a Raspberry PI 3B, and under Windows 10. Connecting to the RP from Windows is no problem, but I’m having a problem when trying to connect from the MX Linux system. When I start NoMachine on that system it shows the RP with the proper name, IP address, etc. However, when I try to connect, the MX Linux screen goes blank for a couple of seconds and then I’m prompted to login to the MX Linux system rather than to the RP!

    I seem to remember that a similar problem was reported by someone trying to connect from a Linux MINT system to a RP, but the user in that case just switched over to Windows 10! I would really prefer to connect to the RP from my MX Linux system, so I hope that this connection problem can be fixed!

    Thanks, Wayne


    It seems the local system is crashing (not nxplayer). Can you send us the system logs (journalctl) and player logs? Please refer to the following document for instructions

    Send them to forum[at]nomachine[dot]com. Please use the title of this topic as the subject of your email. Thanks!

    You could also try disabling hardware decoding in the meanwhile (setting it to “disabled”, as explained in, just to exclude a possible problem with drivers.


    We have checked MX Linux and have not been able to reproduce any similar behaviour. It would have been useful to know the desktop envirionment on the MX Linux system. It could well be crashing. What’s not clear is your setup. Are you are using MX Linux on the Raspberry or are you using a MX Linux NoMachine client to connect to the Raspberry? If the latter, what is the OS and desktop env is on the Raspberry? If you wish for us to investigate further, please provide us with the full set of NoMachine logs as requested from client and server sides? (link in previous reply).

    edit: in your case, using Wayland instead of could help.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.