Newbie can’t connect

Forum / General Discussions / Newbie can’t connect

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #6894

    I am a long-time user of TightVNC, Logmein, Teamviewer, and Google Remote Desktop, but find all of them lacking in some way or another and just stumbled across NoMachine.  It looks great, but I can’t get a connection started.  Here’s the situation. Successfully installed NoMachine (free v. 4.5.0) on home Mac, running the latest version of OSX.  Successfully installed NoMachine (free latest version) on work Linux Ubuntu (latest version).

    When trying to connect from work to home, get error 110: connection timed out.

    When trying to connect from home to work, get error 61: connection refused.

    Have opened port forwarding in home router (D-Link) allowing connection via port 4000.

    When setting up both connections, I chose the option for connect using HTTP proxy.  I’m a bit confused when it asked me to enter the IP address for a second time.  Should that be the same IP address or a different one?  I’m using the same one that I put in at the beginning.  The IP addresses I am using are the ones that show up on opening the NoMachine program. For instance, when opening the home program, I look at the IP address and use that when trying to connect from work.

    The home IP address is dynamic.  The work address is static.

    What I’ve said above is at the limit of my computer knowledge.  I’m not real knowledgeable, but I am willing to learn.


    Hello songjiang,

    In order to help you, we need to know:

    – does your Mac have a permanent IP ?

    – is port 4000 on the router redirected to the IP address of the Mac ?

    – does your home IP address change often ?

    – do you use or something similar ?

    – when you are in the office, do you have the possibility to check if the home IP address has changed ?

    – is the router at work redirected to port 4000 on the IP address of your Linux?


    You don’t need to set the HTTP proxy if you have forwarded the port on the router.

    The following article describes how to connect to NoMachine when the server is behind a firewall:


    Hmm. It looks the problem may be the port on my work router.  I’ll contact my IP people and see if they can open that for me.  Thanks.  Didn’t think of that.

    Everything else looks good.  I tried without a proxy, and got the same problem.  The UPnP is enabled.


    Update.  I managed to get into the work machine from home.  Just had to restart the work machine. Still have the same problem connecting to the home machine, which is what I most want to be able to do.  Restarting that hasn’t helped.


    Hi songjiang,

    It looks like the problem is the home router configuration. Could you please check if NoMachine works OK on the local lan ?

    Please also send us the logs to forum[at]nomachine[dot]com, making sure you reference this topic. It will allow us to check if the problem comes from the router or not.

    If needed, the procedure to follow is explained in the article “How to gather debug logs for support requests” (


    I checked my home IP address again today and got a very different one, and this one worked.  I think it is the difference between the IP address of the individual computer vs. the IP address of the router or modem, the latter being the relevant one for connecting with NoMachine.  Anyway, it works now.  Thanks for your help.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.