NM 6.9.2 fails to connect to Win XP SP3

Forum / NoMachine for Windows / NM 6.9.2 fails to connect to Win XP SP3

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #26402

    Linux mint 19.3 or Mac High Sierra NoMachine clients timeout attempting connection to Windows CP Pro Workstation SP3.

    Interestingly, REVERSE connections work! I.e.., Win XP as client to the Linux Mint OR Mac machines.

    All machines are on same Local lan. Windows XP firewall is off. I can ping the XP machine. I use the XP machine’s IP address, as shown in the XP client, and NX protocol. This is my only NoMachine setup that doesn’t work and it’s the only one with WindowTs XP.

    Text file session Log from LM client is attached.

    Yes I’ve uninstalled, rebooted, reinstalled, etc.

    Anyone know how to have a successful NM 6.9.2 connection to an XP Pro workstation host/server?






    FWIW Using [removed], I can connect to the XP machine just fine. Same connection topology. Only change is using (removed) instead of NoMachine.

    I’m retrying to attach log from my previous post.




      Do you have Windows XP SP3 32bit or 64bit version?
      Reproduce problem, collect logs and send them to forum[at]nomachine[dot]com? Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT10O00163#1.4

    Thanks for replying.

    xp pro workstation sp3 32-bit.

    Which logs? Client or server?




    As the problem is on the server side, we need server logs of the machine you are using “xp pro workstation sp3 32-bit”.





    in the received logs we could not see any incoming connection to port 4000.

    I would ask you to check
    1. if you have firewall blocking port 4000
    2. try to connect to the on that Windows XP

    or try to use different port in nxserver.cfg or use following article https://www.nomachine.com/AR11L00823

    # Specify the TCP port where the NX service is listening.
    NXPort 4000

    No Firewall or antivirus active. When I do, rarely, connect, turning them on makes no difference and I can disconnect and reconnect with them on.

    nc (netvcat) command line utility reports can connect to machine’s IP address. This happens even when nomachine client cannot connect AND after clicking “stop server”

    ” nc -zv 4000
    Connection to 4000 port [tcp/*] succeeded!

    If I use portqry.exe (version 2) on the problem machine, I see that nxserver is always listening on port 4000. And says established if I manage to get a connection.

    I’ve found that repeatedly restarting the nxserver via “server restart” button sometimes allows NoMachine session with this machine. This approach is unpredictable. However, IF it results in being able to connect once. That ability survives connect/disconnect cycles and further server restarts, but NOT rebooting the OS.

    On BOTH of my xp pro sp3, 32-bit machines, havingĀ  installed NoMachine results in this error message on windows shutdown:

    “tasklist.exe unable to locate component. The application has failed to start because framedyn.dll could not be found. Reinstalling the application may fix the problem.”

    Both those files are present, not corrupt and the error is gone when NoMachine is uninstalled.

    This message also appears when NoMachine is restarted.

    Only one of the xp computers has the connection problem. though both show this error message.

    I also notice that the “server status” list box of connection ip addresses has only one or two entries (nx: ) and without any external addresses rather than the many I see in Linux NoMachine server status that have external addresses. All on same LAN.

    Anyway, I’ve wasted a ton of time on this. I think what’s needed is some scrutiny of the logs to see if something is interfering with this instance of NoMachine’s server. Or I need better, straightforward, NoMachine diagnostic tools to see what’s happening in the dialog between machines.



    After serveral attempts we are still not able to reproduce the problem. The only last try is to do what we suggested before: you didn’t tell us if you had tried changing the port.

    What happens if you shut down the server completely the instead of just stopping and then try with netcat again?

Viewing 9 posts - 1 through 9 (of 9 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.