No audio Fedora 38 VM / PipeWire support

Forum / NoMachine for Linux / No audio Fedora 38 VM / PipeWire support

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #45150
    louis2
    Participant

    I installed NoMachine on a Fedora 38 Workstation VM (on TrueNas Scale)…… and I do not manage to get the audio working šŸ™

    During the installation of NoMachine (8.8.1), I get the messageĀ  “The NoMachineĀ  setup procedureĀ  could notĀ  detectĀ  yourĀ  PulseAudioĀ  installation”. Which is logical since modern linux including Fedora38 is using “PipeWire”

    Checking Fedora ^# pactl info^ shows:
    Server : /run/user/1000/pulse/native
    Library protocolversion: 35
    Server protocolversion: 35
    Is Local: ja
    Cliƫnt-index: 80
    Tile size: 65472
    Username: louis2
    Host name: Fedora38WS
    Server name: PulseAudio (on PipeWire 0.3.67)
    Server version: 15.0.0

    In the Fedora GUI, audio settings shows ^Dummy Output^ as device (no other options), which could be wrong despite the fact that it is a VM without a physical audio device.

    Any one know how to fix this !?

    Louis

    #45191
    Britgirl
    Participant

    There is a small bug in the NoMachine node.cfg on Fedora: there is the wrong value set for key AudioInterface during installation on Linux with Pipewire

    The key is set to node.cfg: AudioInterface alsa

    The workaround is to set manually “AudioInterface pipewire” and nxserver --restart

    Please try this and let us know if it helps.

    #45318
    djm
    Participant

    I joined the forum just to thank you for providing the fix.Ā  Changing to pipewire worked for me.Ā  I love using NoMachine.

    #45362
    Britgirl
    Participant

    “I love using NoMachine.” – Thanks for letting us know, and keep nomachining djm šŸ™‚

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.