No available desktops on this server

Forum / NoMachine for Linux / No available desktops on this server

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #44735
    ps.georgiou
    Participant

    I am trying to connect from a Windows 10 (client) machine to a Centos7 (server) using NoMachine.

    On Windows I’ve installed nomachine_8.5.3_1_x64.exe and on Centos7  nomachine_8.5.3_1_x86_64.tar.gz

    To log-in I am using password-based authentication with a username/password which was added to NoMachine’s db. (I was unable to log-in using other methods or the existing credentials of the default user account on the workstation)

    After entering username/password authentication is successful. Then NoMachine is showing the message: “Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?” At this stage I select “Yes”. Then NoMachine seems to start a session but reports “No available desktops on this server”. Clicking on this message expands the message to: “The server was unable to make the local display available or access to the local display is disabled.”

    I’ve tried tweaking with the server.cfg and node.cfg files without any success.

    Please find attached the server log, server.cfg and node.cfg

    The Centos7 workstation is not connected to a monitor and I can do “ssh -x” without any issues.

    In node.cfg I’ve tried using Gnome and Xfce as the default desktops but none of them worked.

    I’d like to use a virtual display although I am not sure whether the configuration is set for virtual or physical display. I believe an X server is running on the workstation since  “echo $DISPLAY” outputs “localhost:10.0”.

    Please let me know if you have any hints on how to resolve this issue.

     

     

    #44744
    ps.georgiou
    Participant

    Re-uploading the files since the upload failed in my original post.

    #44780
    fisherman
    Moderator

    Hello,

    It seems that what you mentioned “The Centos7 workstation is not connected to a monitor” could play a role in the problem that NoMachine does not detect it as available session, and when NoMachine tries to create new display, that request fails as there is already display number used.

    Logs from the server side would be useful. Enable debug on the CentOS 7 machine, reproduce the problem and then gather up the logs.You can send them to forum[at]nomachine[dot]com making sure to use the title of the topic as the subject of your email.

    sudo /etc/NX/nxserver –debug –enable all
    sudo /etc/NX/nxserver –debug –collect
    sudo /etc/NX/nxserver –debug –disable all

    I could propose workaround to try so NoMachine will create new display with a new display number.
    Please edit /usr/NX/etc/node.cfg by enabling key PhysicalDisplays :3 .

    #44788
    ps.georgiou
    Participant

    Thank you for your reply. Please find attached the logs generated while reproducing the issue.

    I will also try the proposed fix and report back.

     

     

    #44790
    ps.georgiou
    Participant

    I have modified the node.cfg file as instructed, and then restarted the nxserver (/etc/NX/nxserver –restart). After doing this, I know see a different error message when trying to connect. This is the new message: “The session negotiation failed. Error: Cannot create a new display, please contact your system administrator”

     

    #44799
    fisherman
    Moderator

    We still did not have full logs, as I have missed to ask after enabling debug logs to restart server and then to reproduce problem. Please can you redo it and then provide us with logs.

    sudo /etc/NX/nxserver --debug --enable all
    sudo /etc/NX/nxserver --restart
    #44804
    ps.georgiou
    Participant

    Hello.

    I have regenerated the log files using these steps:

    • sudo /etc/NX/nxserver –debug –enable all
    • sudo /etc/NX/nxserver –restart
    • sudo /etc/NX/nxserver –debug –collect

    See the attached zip file.

    Note that before reproducing the issue I have modified node.cfg to comment out the key change “PhysicalDisplays :3”

    Thanks.

    #44808
    fisherman
    Moderator

    There was upload error, can you send log file to to the forum[at]nomachine[dot]com?

    #44809
    ps.georgiou
    Participant

    I have emailed the logs. Let me know if there is still an issue. Thanks.

    #44853
    Britgirl
    Participant

    The logs show: “cannot open file `/etc/NX/server/localhost/node.cfg’ for reading (Permission denied)”

    This is what you should change to make it accessible to “read” for all users

    Execute:

    ls -l /etc/NX/server/localhost/node.cfg
    -rw-r--r-- 1 root root 605 cze 30 15:03 /etc/NX/server/localhost/node.cfg

    then you should execute:

    chmod 644 /etc/NX/server/localhost/node.cfg

    This last operation will require admin privileges,

    #44861
    ps.georgiou
    Participant

    After modifying the permissions, a desktop was launched. However, I kept getting a black screen. I then followed the instructions for “Enterprise Desktop” https://kb.nomachine.com/AR03P00973 which also resolved the black screen issue.

    Thanks for your help. I can now launch a remote desktop successfully.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.