No available desktops on this server – Ubuntu 20 LTS

Forum / NoMachine for Linux / No available desktops on this server – Ubuntu 20 LTS

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #37892

    Dear NoMachine team, could you help me, please

    Every time I try to connect to remote Ubuntu I have:

    <No available desktops on this server> 

    Here is the full history of my problem:

    I successfully was able to connect for several months from macOS Big Sur 11.5.1 to Ubuntu 20.04.4 LTS virtual display (which is running on Digital Ocean) via NoMachine. Few days ago I connected to my remote Ubuntu again. It offered me to upgrade NoMachine there and freezed. Last picture I saw was:

    This picture now is showing in the connection info menu constantly.

    When I reconnected again that time,  the black screen was shown to me. I reconnected one more time and got this:

    It seems that a new display has been already started on the requested machine. Do you want to connect to it?
    with Yes No options

    No matter that I choose I get:

    <No available desktops on this server> 

    Then I upgraded Ubuntu’s NoMachine via SSH , but the same problem is still here.

    Some technical info:

    My current NoMachine Version is 7.8.2 on both macOS and Ubuntu.

    I ran this command on Ubuntu side as well:

    ~$ grep ^Exec /usr/share/xsessions/*.desktop


    /usr/share/xsessions/gnome-xorg.desktop:Exec=/usr/bin/gnome-session –session=gnome

    /usr/share/xsessions/gnome.desktop:Exec=/usr/bin/gnome-session –session=gnome

    /usr/share/xsessions/ubuntu.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu /usr/bin/gnome-session –systemd –session=ubuntu

    And I checked the DefaultDesktopCommand here /usr/NX/etc/node.cfg:

    I attached my Ubuntu logs while was reproducing the problem (NoMachine….zip) and .nx catalog from macOS (

    Thanks for reading!


    Hi, can you submit the image again as a separate attachment? or send it to forum[at]nomachine[dot]com and I will upload it to your original topic. Thanks!


    Here it is (see attached Last_NoMachine_Screen) Sorry for the bad quality. It is because I took a screenshot from “Connection Info” menu, which is shown in small window. A notification to upgrade NoMachine is depicted there.

    And I attached here also a screen of the value of DefaultDesktopCommand from /usr/NX/etc/node.cfg in Ubuntu


    Thank you everyone, I solve it.

    I connected to Ubuntu via SSH and ran command “w”.


     13:29:49 up 36 days, 9 min,  2 users,  load average: 0.10, 0.03, 0.02

    USER     TTY      FROM             LOGIN@   IDLE   JCPU   PCPU WHAT

    iv    :1       :1               Mon12   ?xdm?  18:26m  0.00s /usr/lib/gdm3/gdm-x-session –run-script env GNOME_SHE

    iv    pts/1    <macOS IP address is here>   13:29    1.00s  0.02s  0.00s w

    And I noticed that my gdm-x-session is still running according to “?xdm?” value in IDLE field. So I killed this session by PID and reconnected successfully.

    Hope, this may help somebody in the future.

    P.S. to get PID ran:

    who -uH

    P.P.S  to kill by PID ran:

    sudo kill -HUP <PID is here>


    thanks for updating your topic. I’m glad to know you fixed the issue. From what you described you have a headless Linux. We have an article in our knowledge base which provides guidelines for Connecting to Linux headless machines with NoMachine such as disabling the Xserver. You can find it here: If NoMachine detects that the X server is already running, it doesn’t use its own virtual display and that is what triggers the “no available desktops” message.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.