'No available sessions on this server' error for Ubuntu 14.04.4

Forum / NoMachine for Linux / 'No available sessions on this server' error for Ubuntu 14.04.4

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #10146

    I’ve been using NoMachine (free version) successfully and without problems (for years) until a few days ago. I’m now getting the dreaded “No available sessions on this server” error on the NoMachine client (on OSX) when trying to connect to a physical display, with the further info: “The server was unable to make the local display available or access to the local display is disabled.”

    nxserver is 5.0.63 on Ubuntu 14.04.4 (updated to the .4 release a few days ago, which may correspond to when this stopped working…I’m not clear…). I updated the server version (from a slightly older version) today to try to resolve this, but no impact on results or error messages. Also completely uninstalled nxserver and reinstalled from scratch, still no dice. The Ubuntu workstation is running XFCE desktop.


    Client is 5.0.63 on Mac/OSX (El Capitan).

    The server machine is not a headless client (the cause of most of these reports that I see in the forums..). It is a regular workstation machine, with X (and lightdm) running. With a single X display screen on :0.

    I’ve dug around the log files, increased verbosity, but dont see anything in particular jumping out (but there is tons of info in there….). It does register that I’ve logged in successfully, but apparently cannot start up the display.

    Thanks for any suggestions, or let me know if specific info from the logs would be helpful.



    Hi, can you enable debug and submit logs? Instructions are available here: https://www.nomachine.com/DT07M00098

    Send them on to forum[at]nomachine[dot]com making sure to reference your topic.



    It seems that the problem you have encountered most likely is caused by a corrupted nodes.db
    configuration file.

    During uninstall procedure we save the backup configuration files in /usr/NX/etc directory, so
    reinstalling will preserve this problem. The safest option is to uninstall NoMachine, make sure
    the /usr/NX/etc/nodes.db.backup file is removed, then install again.

    You can also edit /usr/NX/etc/nodes.db.

    The file should look like:


    The problem will occur when first entry is different from “running”.


    Ah….thanks very much, after uninstalling, then manually┬áremoving the install directories /usr/NX, and reinstalling, its working again!


Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.