No error but no connection

Forum / NoMachine for Linux / No error but no connection

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #4618

    Recently installed NoMachine on my Opensuse 13.1 Linux server. Tried connecting from Win 7 host and my Android device, but no connection.


    When I connect from my Win 7 machine I dont get any errors


    NX> 203 NXSSH running with pid: 11780

    NX> 285 Enabling check on switch command

    NX> 285 Enabling skip of SSH config files

    NX> 285 Setting the preferred NX options

    NX> 200 Connected to address: on port: 4000


    my linux server shows the NX status below

    NX> 161 Enabled service: nxserver.

    NX> 161 Enabled service: nxnode.

    NX> 161 Enabled service: nxd.




    I confirmed that its not the firewall



    the logs excerpt are from version 3.5.0 client. NX 3.5.0 is now dealt with via the traditional support channels, so I suggest you use the contact us link at the bottom of the website if you need further information about backward compatibility between versions. That said, the logs show that you are trying to connect using SSH (port 22), and SSH is not supported in the free NoMachine server.  Try installing the NoMachine 4 client on Windows and report back. By default it uses port 4000 (NX protocol). If you want to continue using port 22, you need to install the Workstation on the remote server host.

    Related post:


    i was able to resolve some of this issue. but still unable to connect from my android. i tried saving the log file but the application will not let me select the file that i created.

    is there additional configuration to setup the NX protocol on the Linux server?


    Are you using the latest Android version?

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.