No external IP address shown in server on Windows 10

Forum / NoMachine for Windows / No external IP address shown in server on Windows 10

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #17230
    otlichnik73
    Participant

    Hi there everyone, I know there have been some discussions about this, but did anyone find a solution:

    Stand-alone desktop with Win10   –  NoMachine server does not display external IP address, only local address in GUI.

    Tried it all – UpnP is enabled, firewall disabled.

    Use NM on four machines, 2 windows and 2 Linux, some on LAN some over internet. Three are working fine with firewall on and everything, but this one sucker just won’t go…

    Thanks!

    Thanks!

    #17252
    irek
    Participant

    Hello otlichnik73,

    we would need some more information:

    1. The Router name and model to which the problematic Windows machine
    is connected.

    2. You mention you checked whether UPnP is enabled, you mean you checked it on the router which is attached to the problematic Windows machine?

    3. Are there any other machines connected to that same router and which don’t have problems with port mapping?

    4. Please enable debug, restart nxserver, reproduce the problem and cmd.exe as root (Administrator) and show us the result of the following commands:


    C:\Program Files (x86)\NoMachine\bin\nxserver.exe –upnpmap
    C:\Program Files (x86)\NoMachine\bin\nxserver.exe –upnpstatus

    Please do this on 2 servers connected to the same router. One must
    be the Windows server where port mapping is not working, and second any
    of the servers where port mapping is working.

    Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT10O00163.

    Please send them to forum[at]nomachine[dot]com making sure to reference the topic.

    • This reply was modified 6 years, 5 months ago by irek.
    #17400
    otlichnik73
    Participant

    Hi there Irek thanks for you help.

    Well, I am a bit of a tech dummy, but followed the steps in the link you mentioned and this is compressed folder of the logs, I think … (attached)

    But trying to run the commands you asked for just get that: “C:\Program not recognized as command or operable batch file”

    I’m sure I’m getting something basic wrong …

    Thanks for your patience

     

     

    Attachments:
    #17402
    otlichnik73
    Participant

    irek, aren’t those linux commands? I’m in windows 10 on problematic machine

    #17415
    irek
    Participant

    Hello otlichnik73,

    Server logs weren’t enabled, so please do:

    1. Open cmd as an administrator.

    1.4. Server on Windows
    Step 1 – Set debug level in server.cfg
    Copy the InstallationDirectory/NoMachine/etc/server.cfg file in a temporary folder and open the file with an editor like WordPad. This is necessary for being able to edit the file.

    Edit the copy of the server.cfg file, uncomment and set the following:

    Change from:

    #SessionLogLevel 6

    To:

    SessionLogLevel 7

    Copy the modified server.cfg file to InstallationDirectory/NoMachine/etc/server.cfg. Administrative privileges are required.

    2. Restart nxserver, open cmd as an administrator, and execute:

    "C:\Program Files (x86)\NoMachine\bin\nxserver.exe" --restart

    3. Wait few minutes, and reproduce the problem, open cmd as an administrator, and execute:

    "C:\Program Files (x86)\NoMachine\bin\nxserver.exe" --upnpmap
    "C:\Program Files (x86)\NoMachine\bin\nxserver.exe" --upnpstatus

    Please do this on 2 servers connected to the same router. One must
    be the Windows server where port mapping is not working, and second any
    of the servers where port mapping is working.

    Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT10O00163.

    Please send them to forum[at]nomachine[dot]com making sure to reference the topic.

    4. The Router name and model to which the problematic Windows machine
    is connected.

    5. You mention you checked whether UPnP is enabled, you mean you checked it on the router which is attached to the problematic Windows machine?

    6. Are there any other machines connected to that same router and which don’t have problems with port mapping?

    #17446
    Britgirl
    Keymaster

    Logs received, but only from one of your computers. Did you send a second set separately?

    #17448
    irek
    Participant

    Hello otlichnik73,

    from the logs we can see that debug level wasn’t enabled – or at least it wasn’t enabled on the machine from which you sent logs.

    On the affected machine which you are connecting -to- please follow the instructions as above, making sure

    Change from:

    #SessionLogLevel 6

    To:

    SessionLogLevel 7

    and restarting the server.

    Could you please give us the info for points 4, 5 and 6 as well? Thanks.

Viewing 7 posts - 1 through 7 (of 7 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.