No folder in Application Support

Forum / NoMachine for Mac / No folder in Application Support

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #46479
    luca
    Participant

    Hi all

    I am using NoMachine 8.10.1 to connect to a remote Mac from a Mac laptop running 10.13.4. Normally I use a different laptop and everything works fine. On this laptop, there is no connection at all, and the wheel keeps spinning.   I can ping the remote IP. In .nx the nxserver.log file is empty (although I ticked the “Don’t delete the log files on exit”). Looking around, I find that there is no folder NoMachine inside /Library/Application Support. I removed and reinstalled NoMachine several times, no luck. I’ve chmod the permissions of Application Support to 755, following some advice found here. Still no luck, the wheel spins forever and I do not get any error message. Any suggestion?

     

    #46486
    zaq
    Participant

    Hello Luca,

    we would need some additional information, could you please send to us part of system installation log?

    The path to the file is:

    /var/log/install.log

    You can send us the whole file or just the part related to NoMachine.
    The NoMachine part starts from line:

    Installer[63841]: NoMachine  Installation Log

    and ends:

    Installer[63841]: PackageKit: Registered bundle file:///Applications/NoMachine.app/ for uid 501
    installd[2151]: PackageKit: Removing client PKInstallDaemonClient pid=63841, uid=501 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
    Installer[63841]: Running install actions
    Installer[63841]: Removing temporary directory “/var/folders/t1/tsyt3p3n26535k7zkprz_6cc0000gn/T//Install.63841aOvI28”
    Installer[63841]: Finalize disk “Macintosh HD”
    Installer[63841]: Notifying system of updated components
    Installer[63841]:
    Installer[63841]: **** Summary Information ****
    Installer[63841]:   Operation      Elapsed time
    Installer[63841]: —————————–
    Installer[63841]:        disk      0.01 seconds
    Installer[63841]:      script      0.00 seconds
    Installer[63841]:        zero      0.00 seconds
    Installer[63841]:     install      27.20 seconds
    Installer[63841]:     -total-      27.21 seconds
    Installer[63841]:
    Installer[63841]: IFDInstallController BC600 state = 5
    Installer[63841]: Displaying ‘Install Succeeded’ UI.

    Alternatively during installation you can call log window by clicking Command + L (⌘L). In the installer log window choose:

    Show All Logs‘ and after that ‘Save‘.

    Please send the file with installation logs to forum[at]nomachine[dot]com.

    #46488
    luca
    Participant

    Thanks. I just sent the log (although it’s called nxinstall.log, not install.log, and is in /Library/Application Support/NoMachine/var/log rather than in /var/log). In the meantime, I found the missing folder (sorry, I was looking in the wrong subfolder, my bad), but I still can’t connect, with no error message. The nxserver.log is full of lines like this:

    \103 15619 2023-12-27 15:07:04 882.848 NetworkChange: WARNING! Interface name is not available.

     

     

     

    #46541
    zaq
    Participant

    Hi,

    In your first post you reported lack of:

    /Library/Application Support/NoMachine

    In the directory there are NoMachine installation logs. Because of missing
    log dir I asked you about system installation logs:

    /var/log/install.log

    Now you confirmed that you have /Library/Application Support/NoMachine
    and you sent NoMachine nxinstall.log. In the log file I couldn’t find reason
    of your problems. Please send another pack of logs as it’s described in:

    https://kb.nomachine.com/DT11R00182

    A possible solution can be approving NoMachine mandatory security permissions:
    – Screen Recording,
    – Accessibility.

    A related article:

    https://kb.nomachine.com/AR11Q01061

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.