No GPU after uninstalling NoMachine

Forum / NoMachine for Linux / No GPU after uninstalling NoMachine

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #47919
    twinnie
    Participant

    After lots of troubleshooting I eventually discovered that the reason my graphics card wasn’t working was because of NoMachine. I’ve read that there’s a udev rule “99-virtualgl-dri.rules” that needs to be deleted but even after deleting it my issues remained. I also tried disabling all the graphics hardware rendering options from NoMachine server and then uninstalling it but it didn’t fix anything. The only solution to keeping my graphics card working right now is to have NoMachine installed.

    I read on a Fedora thread that some people had noticed permissions to their devices under /dev/dri had been changed, but mine seem to be okay:

    me@me-linux:~$ ls -l /dev/dri/
    total 0
    drwxr-xr-x. 2 root root       80 Apr 22 18:51 by-path
    crw-rw-rw-+ 1 root root 226,   0 Apr 22 19:19 card0
    crw-rw-rw-. 1 root root 226, 128 Apr 22 18:51 renderD128

    I’m running Fedora 39 and I have a Geforce 2060 Super. Here’s the link to my thread on the Fedora board:

    https://discussion.fedoraproject.org/t/nvidia-drivers-appear-to-be-installed-but-they-arent-being-used/113531/19

    #47927
    Britgirl
    Keymaster

    Hi, Did you do a reboot after removing the leftover file as in the TR (https://kb.nomachine.com/TR04V11131). I’m assuming you did but I have to make sure.

    If you did, can you try this instead as user root?

    Make a copy of the following files

    /usr/NX/scripts/vgl/vglserver_config 
    /usr/NX/scripts/vgl/vglgenkey 

    making sure to place them in the same folder

    Uninstall

    Execute <path_to_folder_with_copied_files>/vglserver_config -unconfig

    Reboot

    #47954
    twinnie
    Participant

    Yep, I had restarted. That script did the trick though, it’s all working now. Thanks.

    #47960
    Britgirl
    Keymaster

    Good to know 🙂 The fix will be in the next maintenance, 8.12.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.