No hardware encoding on Ubuntu 22.04 LTS Intel HD Graphics 520

Forum / NoMachine for Linux / No hardware encoding on Ubuntu 22.04 LTS Intel HD Graphics 520

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #45235


    I was aware of this issue but ignoring because I did 5-10 minute connections. Now I may have to connect for hours, music plays at the device for an entire restaurant and because of both spotify and nomachine using the CPU, some audio glitches/ overheat started to occur.

    I am using Ubuntu 22 LTS on a Lenovo laptop well supported on Linux. Nothing modified at kernel etc. vainfo shows:

    libva info: VA-API version 1.14.0
    libva info: User environment variable requested driver ‘iHD’
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/
    libva info: Found init function __vaDriverInit_1_14
    libva info: va_openDriver() returns 0
    vainfo: VA-API version: 1.14 (libva 2.12.0)
    vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics – 22.3.1 ()
    vainfo: Supported profile and entrypoints
    VAProfileNone                   : VAEntrypointVideoProc
    VAProfileNone                   : VAEntrypointStats
    VAProfileMPEG2Simple            : VAEntrypointVLD
    VAProfileMPEG2Simple            : VAEntrypointEncSlice
    VAProfileMPEG2Main              : VAEntrypointVLD
    VAProfileMPEG2Main              : VAEntrypointEncSlice
    VAProfileH264Main               : VAEntrypointVLD
    VAProfileH264Main               : VAEntrypointEncSlice
    VAProfileH264Main               : VAEntrypointFEI
    VAProfileH264Main               : VAEntrypointEncSliceLP
    VAProfileH264High               : VAEntrypointVLD
    VAProfileH264High               : VAEntrypointEncSlice
    VAProfileH264High               : VAEntrypointFEI
    VAProfileH264High               : VAEntrypointEncSliceLP
    VAProfileVC1Simple              : VAEntrypointVLD
    VAProfileVC1Main                : VAEntrypointVLD
    VAProfileVC1Advanced            : VAEntrypointVLD
    VAProfileJPEGBaseline           : VAEntrypointVLD
    VAProfileJPEGBaseline           : VAEntrypointEncPicture
    VAProfileH264ConstrainedBaseline: VAEntrypointVLD
    VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
    VAProfileH264ConstrainedBaseline: VAEntrypointFEI
    VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
    VAProfileVP8Version0_3          : VAEntrypointVLD
    VAProfileHEVCMain               : VAEntrypointVLD
    VAProfileHEVCMain               : VAEntrypointEncSlice
    VAProfileHEVCMain               : VAEntrypointFEI

    GPU is:

    00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)

    apt-file search
    intel-media-va-driver: /usr/lib/x86_64-linux-gnu/dri/
    intel-media-va-driver-non-free: /usr/lib/x86_64-linux-gnu/dri/
    (there is also another one at /opt/intel/mediasdk/lib64 )


    Have you already tried the tips in the second option in this article?

    How to use Intel H.264 HW encoder with NoMachine on Linux platforms



    I had Intel Media SDK installed but to make sure, I went with Step 2. I removed the /opt/intel folder and built & installed my own current stable Intel media SDK carrying the instructions at

    I am also a bit confused with having intel-media-va-driver-non-free (deb) installed from Ubuntu but when I check the files via dpkg -L they don’t seem related.

    Unfortunately, on log (and client) I noticed it isn’t encoding in hardware. However, using Bing Chat (actually GPT4), the following trick it probably got from these forums fixed the issue. I really don’t think a VM will be able to access quicksync encoding though.:

    <div class="content" style="color: #000000; font-size: medium; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; white-space: normal; text-decoration-thickness: initial; text-decoration-style: initial; text-decoration-color: initial;" tabindex="0">
    <div class="ac-container ac-adaptiveCard">
    <div class="ac-textBlock">

    I found a forum post that explains how to enable hardware acceleration for NoMachine-server in Ubuntu VM <sup>1</sup>. According to the same source, the following steps might help you enable hardware acceleration via Intel’s QuickSync on the NoMachine node server:

    1. Install intel-media-va-driver-non-free and libmfx1 packages using the following command:
    sudo apt install intel-media-va-driver-non-free libmfx1
    1. Create a directory named /opt/intel/mediasdk/plugins using the following command:
    sudo mkdir -p /opt/intel/mediasdk/plugins
    1. Create a symbolic link to /usr/lib/x86_64-linux-gnu/dri using the following command:
    sudo ln -s /usr/lib/x86_64-linux-gnu/dri /opt/intel/mediasdk/plugins
    1. Restart the NoMachine server.

    Please note that these steps are specific to Ubuntu VM and might not work for other Linux distributions. If you encounter any issues, please refer to the NoMachine Knowledge Base or contact their support team for further assistance <sup>2</sup>.

    I hope this helps!




    Thank you for sharing your information.

    Have a nice day.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.