No sessions available on Ubuntu

Forum / NoMachine for Linux / No sessions available on Ubuntu

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #24980

    I am trying to connect from Arch Linux to Ubuntu Linux (18.04LTS) both using the latest version of NoMachine. When I try to connect I get an error stating that there are no available sessions on the Ubuntu server. I am attaching the serverside logs. Any help would be much appreciated.


    Hi jjgalvez,

    The upload of your logs failed. Please collect logs (both server and client sides), following the procedure explained in this document, and send them to forum[at]nomachine[dot]com, making sure to reference this forum topic.

    Thank you


    The log files are too large to send via email. Do you have a dropbox or similar service I can use?

    Thank you


    Please make sure you don’t have old sessions in the log file, it’s important you send us the logs of the attempted session which is affected.  If they are still too big, you can try splitting them up.


    Thank you log files uploaded as requested



    From the logs it seems that there is a problem with installation. We have:

    /usr/NX/bin/nxnode.bin: symbol lookup error: /usr/NX/lib/ undefined symbol: deyaultPoi9terContSol

    There are no nxinstall or nxupdate logs included, so I am not able to tell, but was it a clean installation? Maybe there was some directories left from previous one?

    The log suggests some kind of modified, old or broken libraries present, so right now the only thing to do would be a clean installation.

    If you have version free or evaluation, it is probably safe to ignore points 1, 5 and 6 of this instruction.
    It is only relevant if you have received custom license files from us or using modified configuration files.

    1. Backup all the modified files from /usr/nx/etc directory (important to keep .lic files if you are a customer
    with custom license and .cfg or .db files when modified)
    2. Uninstall NoMachine.
    3. Remove /usr/NX, /etc/NX and /var/NX directories if they still exist.
    4. Install NoMachine.
    5. Restore backed up licenses as per article.
    6. Restore backed up cfg and db files.

    Please let us know if it helped, or if the issue persists after reinstall.




    Thank you that worked! it seems that I some how messed up the install when I did that last update. The clean install fixed it. Should have tried that first. Thank you again for a great product and for letting us us home users use if for free! I would not help my mother without you!

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.