No sound after recent update

Forum / NoMachine for Linux / No sound after recent update

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #46919
    road hazard
    Participant

    I’m a home user and have been connecting to my 2, Linux (Debian 12, Cinnamon desktop) boxes from my Windows 11 box for a long time with zero problems. I recently updated both Linux boxes and Windows to v8.11.3 (free version) and now the sound doesn’t work.

    Before, I could play a YouTube video on either Linux box when I was remotely connected from Windows and I could hear the sound perfectly fine. When I walk around the corner and physically log into each Linux box, audio is fine…. just isn’t working remotely.

    Now the super weird thing…… as I was collecting debug log files, after I issued this command on one of the Linux boxes:

    nxserver –debug –enable all

    ….and tried to reproduce the problem, my sound started working!!

    I then typed: nxserver –debug –disable all

    …and sound is still working!

    I tried doing this on the 2nd box and no such luck. Attaching debug logs from the still broken system.

     

    #46954
    road hazard
    Participant

    UPDATE: Before I posted this originally, I did try removing and reinstalling but the 2nd time around, I did a ‘purge’ after removing it and reinstalled and it’s AOK now.

     

    #46960
    Britgirl
    Participant

    Hi, if I understand what you wrote, I think that running the “nxserver --debug --enable all” and then sound came back was just a coincidence. If you have problems with sound again within the NoMachine session (from Windows to Linux), submit logs from the server.

    #46973
    Britgirl
    Participant

    If it happens again, check to see which sound server is being used on the server host?

    Please open /usr/NX/etc/node.cfg on the server host and check which value is set for the AudioInterface key. If they are different, set AudioInterface to the appropriate sound server.

    For example, if “AudioInterface pipewire” is set in server.cfg but the sound server
    is PulseAudio, set the key to: “AudioInterface pulseaudio” .

    Then create a new session. If this doesn’t help, we will need the logs as I suggested before.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.