NoMachine 6.9.2 unstable connection to MB pro Retina H.Sierra clamshell mode

Forum / NoMachine for Mac / NoMachine 6.9.2 unstable connection to MB pro Retina H.Sierra clamshell mode

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #26059

    I want to connect from my Linux Mint 19.3 machine to a Macbook Pro Retina (mid 2015) w/ High Sierra (as the “server”) with cover closed on same LAN segment. Using the same procedure I use to connect to other Linux Mint Thinkpads in clamshell mode doesn’t work with the Macbook. The Macbook connection is either black screen or keeps reverting to lock screen (Not initial login screen) though I’ve provided login credentials already.

    If I power on the external monitor, NoMachine connection is stable. Turn it off and client screen goes black and then changes to lock screen on mac.

    Mac is on AC power. External monitor is connected via Thunderbolt (displayport) to Dell 4K monitor. I’ve turned off the screensaver, energy saver > sleep settings, etc. on the Mac.

    Caffeinate with various options run in Mac terminal doesn’t help.

    So, any idea how to get this to work with Mac in “headless” mode?





    macOS when lid is closed does not update the screen content, that’s why Caffeinate is only good for background tasks or ssh. If you don’t want others to see your screen, you can try using screen blanking. You can find more info about this feature here


    Thanks for the reply. The screen blanking does blank my screen, but it’s the closed lid operation that seems to have worked in the past I seek. I’m hoping someone knows the incantation that currently works.

    Having now spent too much time researching this issue, it seems using Macbook pro retina with High Sierra in Clamshell mode with lid closed and no external display is mostly about the Mac Lid closed action forcing sleep. There used to be ways around this, but they seem to be deprecated / no longer work. E.g. InsomiaX, Amphetamine, etc???

    Tools that relied upon terminal command pmset -c disablesleep 0 may no longer work as it seems disablesleep option is no longer offered.

    I notice that nomachine seems to insert coreaudiod to prevent sleep, but seems not to work in clamshell mode.

    e.g., Mac system monitor> all processes. “preventing sleep column” shown, all processes show no.

    FWIW, pmset -g command reports

    System-wide power settings:
    SleepDisabled        0
    Currently in use:
    standbydelay         10800
    standby              1
    womp                 1
    halfdim              1
    hibernatefile        /var/vm/sleepimage
    powernap             0
    gpuswitch            2
    networkoversleep     0
    disksleep            0
    sleep                0 (sleep prevented by coreaudiod)
    autopoweroffdelay    28800
    hibernatemode        3
    autopoweroff         1
    ttyskeepawake        1
    displaysleep         0
    tcpkeepalive         1
    acwake               0
    lidwake              1

    With these settings, closing the lid results in no nomachine window going black in about 35s and then “attempting to reconnect” that times out. If I reopen the lid I get the remote screen back as it was. So lid closing is still forcing sleeping.

    Here’s the log of power actions for a cycle of closing and opening lid.

    pmset -g pslog
    Logging IORegisterForSystemPower sleep/wake messages
    pmset is in logging mode now. Hit ctrl-c to exit.
    2020-03-23 10:20:28 -0700 IOPSNotificationCreateRunLoopSource
    Now drawing from ‘AC Power’
    -InternalBattery-0 (id=4587619)    100%; charged; 0:00 remaining present: true

    2020-03-23 10:20:45 -0700 IORegisterForSystemPower: …Sleeping…

    2020-03-23 10:20:50 -0700 IORegisterForSystemPower: …HasPoweredOn…
    Wake Reason = EC.LidOpen
    wakeType = HID Activity

    Still hoping for resolution.

    Thanks much for the help!



    Problem maintaining stable connection is due to mac laptops need for an active display to not sleep their GPU. When lid closed without active external monitor connection, mac goes to sleep no matter what built-in settings are set.

    So need a way to fake an active display or defeat Apple’s default lid closed action.

    Antisleep app (in apple store. Costs small $ for necessary functions) for mac app defeats the lid close action with “prevent sleep with lid closed” menu option.

    Alternative is a mini-displayport display emulator plugged into thunderbolt port to fake presence of active display.

    Do either and you can close the lid on the mac and maintain a NoMachine connection. At least with Macbook Pro Retina mid2015 on AC power.

    Huge waste of time for such an obviously useful need.

    Thanks for playing 😉



Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.