NoMachine 7.3.2 now available for download

Forum / General Discussions / NoMachine 7.3.2 now available for download

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #32445

    We’ve just released a minor software update which is aimed at fixing some issues affecting the previous version such as muted audio in macOS remote desktop sessions and wrong cursor shape and position on Wayland desktop. Additionally, this release implements the possibility to enable forwarding of system groups set on Enterprise Terminal Server to its Terminal Server Nodes, and cosmetic UI improvements to Cloud Server web-based connections.

    Full list of what’s included is here:


    Hi Britgirl and NM team

    I’ve read through the update log for 7.3.2, and I didn’t want to start a new thread or issue just in case it’s isolated to my PC.

    I looked at 7.2.3 and I don’t see any mention of this issue.


    Lately I’ve been experiencing some issues with both NoMachine and my “internet”.

    In last week my internet has completely dropped out, I can’t seem to ping my domain or google, all of “internet” seems to stop working after a while of using NoMachine, if I close down or if the player times out I get back “internet”.

    I’ve tried to look for a cause on this PC, but I can’t seem to pin point the cause other then it looks like the nxplayer seems to be the cause of it. On the same network all of the other machines work fine but non of them are connecting to a nxserver, when ever I connect to my machine I’ll get ping failures/my internet will drop for 10-60 seconds until I either close down the active NX window or it times out (after 2min) this happens at random times, idk how long it takes some times it’s half a day, and some times it’s within the hour.

    Is there a way to log something from the nxplayer to see what is wrong with the NX install on the client side?  when I look at the ping or general log of the servers everything seems fine, On the server I keep a constant ping to google and no packet has been dropped since boot/disconnect, and the servers has been up and running for 88 days (one server I use), 24 days (host server),  2 hours ( god d*** windows 10 update, it should be 24 days as it’s the guest machine that I mainly use that runs on the host).

    I really don’t know how to label this issue, how to properly explain it, where to post, or where to look for a solution.

    I just know that if my connection is randomly lost, and that causes my background ping loses “google” it will quickly and without fail pick it up if I close the nxplayer window (disconnect), if nxplayer is kept running internet for the machine will be unstable.

    I’ve tried WIFI, LAN, (USB) LAN over android, and WIFI over android, so it’s not a modem issue, it’s either a computer specific issue or something with nxplayer. Since I can’t seem to reproduce the issue on any computer I have… I don’t where to look for other then a client side log, that I can’t seem to generate with enough detail.


    Hi Gatos,

    very strange…..can you send us the player side logs (follow the instructions here: and then send them to forum[at]nomachine[dot]com.

    After you’ve done that, could you then try disabling UDP? Do you still encounter the same the same behaviour?


    Hi Britgirl

    I’ve sent the logs now, sorry for the delay.


    I did in fact try disabling UDP yesterday, and the last 2-3 sessions in the log were done without UDP and I still encounter the same problem.

    For reference since I forgot to mention it in the original post, the client machine is running Windows 7 and the server is running windows 10 (in a VM).

    I’ve had the same setup for years and that’s the first time I’ve had crippling issues like that, hence why the client is still running Windows 7. it only occurs a seemingly random amouny of time after using NM and it’s only fixed by rebooting the machine, if I don’t reboot it will become unstable and the client will just drop any connectivity to the internet as long as the NX player is connected/trying to connect to the server.


    I’ve tried to single out a cause, or causes, but I just don’t understand what’s going wrong here so let’s hope the logs help out 🙂


    Hi Gatos,

    Unfortunately, we were not able to reproduce the problem and couldn’t find anything in the logs that explains what’s causing the issue.

    We kindly ask you to reproduce the behavior, and check system events (e.g. with Event Viewer) and also in Resource Monitor the nxplayer there (mostly in the ‘Network’ tab).

    Could you please check this and send us screenshots as shown in the images attached? Screenshots of anything you find suspicious might also help with the investigation. You can send your images directly to forum[at]nomachine[dot]com making sure you use the title of the topic in the subject of your email? Many thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.