NoMachine 7.9.2 on 2022-04-04-raspios-bullseye not working?

Forum / NoMachine for Raspberry Pi / NoMachine 7.9.2 on 2022-04-04-raspios-bullseye not working?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #38674

    I’ve hit a brickwall with this configuration: nomachine_7.9.2_1 on 2022-04-04-raspios-bullseye

    A clean installation of bullseye 2022-04-04 proceeds correctly.

    I’ve tried the 64bit (~800Mb) and the 32bit (~2.5Gb) versions of bullseye

    I can do ALL the required steps – ‘new’ username (we frown on the username ‘pi’ apparently these days), config the display to remove (or even keep) the black margins, etc etc.

    I can assign new hostnames and get asked to reboot… ALL the usual stuff you can do installing an OS onto RPi.

    BUT the moment I try to install nomachine armhf onto the OS that has armhf, the install completes, and reboot takes me into a black screen, never to return…

    I’ve tried this on an 8Gb RPi4 and a 4Gb RPi4.

    SD cards are either Samsung 64Gb or Lexar 32Gb cards.

    I’d prefer to believe I’m doing something wrong rather than “it doesn’t work”, but right now, tbh, I think “it doesn’t work”.
    I use NoMachine on Windows, Linux and RPi3’s and 4’s, but Bullseye seems to have scuppered it.

    Any other troubleshooting suggestions ?



    Attached : Picture of a large black rectangle ­čśë


    After backtracking and double checking, I found my mistake.

    I needed to download and apply the aarch version of nomachine.

    uname -a gave me the following:

    Linux goldenpi 5.15.32-v8+ #1538 SMP PREEMPT Thu Mar 31 19:40:39 BST 2022 aarch64 GNU/Linux

    So aarch64 was the clue that led me to NoMachine for Raspberry ARMv8 DEB

    Hope that helps someone else.


    Thanks for letting us know.

    Just as a side note for all Raspberry users, you can consult the article in our knowledge base which outlines which packages you should install depending on the architecture of your RPi.

    Installation & configuration notes for NoMachine Linux Raspberry Pi packages

    Quoting said article:  To check what architecture your Raspberry based on, open a terminal on your device and run the uname -m command. Some examples:

    armv6l – means that you should useARMv6 packages
    armv7l – means that you should use ARMv7 packages
    aarch64 – means that you should use ARMv8 packages

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.