NoMachine 8.10.1 Pipewire – no sound from server without physical sound card

Forum / NoMachine for Linux / NoMachine 8.10.1 Pipewire – no sound from server without physical sound card

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #46773
    HonestCoder
    Participant

    Hello.
    I have VPS on CentOs 8 Stream, and use it from remote Fedora 39. Both use pipewire. CentOs does not have physical sound card.
    I load dummy sound by add /etc/modules-load.d/vsound.cfg with sbnd-dummy in it. Now I have sound devices on CentOs

    I setup pipewire-utils at Centos, and have pw-cli here (NoMachine need it to detect pipewire). I set UDPPort 4800-4999 in server.cfg on CentOs. I open incoming connection to these ports on the side of CentOs (was it necessary ? What ports may be open for incoming connections on client and server ?)

    Anyway, I do not listen any sound from server on my client Fedora. Also I try to intercept 4800-4999 UDP port range at CentOs. It is no any packets on it`s, then I try to play any sound at CentOs server.

    What is wrong ?

     

     

    #46781
    HonestCoder
    Participant

    Try to replace PipeWire on Puilseaudio, as in FAQ of NoMachine.
    For CentOs 8 by commands:
    dnf remove pipewire
    dnf install alsa-plugins-pulseaudio
    systemctl –global enable pulseaudio.service
    /usr/NX/scripts/setup/nxnode –audiosetup

    Do not help.
    No sound on client
    No UDP packages (excl main port) from server, then try to check sound play on server.

    Please help.

    #46782
    HonestCoder
    Participant

    Sound appear after changed, described in my post upper, but after 1-2 minutes.
    Problem for server without sound card solved

    #46814
    Britgirl
    Participant

    Thanks for the update. We’re glad to know it’s now working 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.