NoMachine always starts a new user session even on disconnect

Forum / NoMachine for Linux / NoMachine always starts a new user session even on disconnect

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #18190

    Hi there guys.

    As the title says, i’m using NoMachine on Linux (Ubuntu 16.04.1 LTS). When i connect to the remote host (which is linux as described before), and then disconnect, when i try to reconnect to it at a later time, i will always login into a new user session even if i choose disconnect and not terminate.

    I have set in the /usr/NX/etc/server.cfg this option too:

    ConnectPolicy autocreate=1,autoconnect=1,automigrate=1,desktop=0,dialog=1

    for have a notification dialog on disconnect but even when i choose disconnect on the dialog window, it will always starts a new user session, no matter what i choose. Any way to make it work?

    Thank you!


    Open a terminal on the server and tell me what output you get for:

    sudo /etc/NX/nxserver --version


    sudo /etc/NX/nxserver --list



    Sure. Here we are:


    sudo /etc/NX/nxserver –version

    NoMachine – Version 6.1.6

    sudo /etc/NX/nxserver –list

    NX> 127 Available sessions:

    Display Username Remote IP    Session ID                       Node

    ——- ——– ———— ——————————– ————–

    1001    user    D99749118F05BF54DB38EA7AEFBBBB0D localhost:4000

    1002    user     (my current ip, i delete it for privacy) BF3B57FE1221237C34AA6AC70C4CED05 localhost:4000



    Can we take a look at the logs? You’ll need to enable debug, reproduce the issue and then extract the logs.

    Send them to the usual email address you’ve used in the past.


    ok log sent by email.



    This problem may be caused by the server.cfg key ‘EnablePersistentSession’
    Please make sure that username ‘user’ is listed there, or it is set to the default ‘all’
    value or commented. Valid key values for this case would be:

    EnablePersistentSession user
    EnablePersistentSession all
    #EnablePersistentSession <any_value>

    I can see no hint of it in logs, but please also make sure that the key
    DisablePersistentSession does not list this ‘user’.

    Please let us know if this does not help with the issue.




    Thank you for the help: with your setting everything works good.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.