NoMachine audio still not working in Catalina

Forum / NoMachine for Mac / NoMachine audio still not working in Catalina

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #25746

    Hello, I have several macOS machines with fresh installs of macOS Catalina running NoMachine 6.9.2 and am finding that audio back to the local user is still not working. I have tried the kext permissions workaround suggested in the help docs, checking MIDI settings and ensuring the local user (also 6.9.2) has their correct audio output device selected and it’s still not working. This has been working in previous version of NoMachine.

    Any help or ideas will be greatly appreciated.

    Thank You!



    Can you validate audio devices? Remote audio output should be set to NoMachine Audio Adapter but local to the physical device. What about kext? Is it mounted? You can verify this using the Terminal sudo kextstat | grep nx. The output should contain “com.nomachine.driver.nxau”.

    What’s more you can check if kext is approved. To do this: open the System Preferences -> Security & Privacy -> General panel on your Mac and click on the ‘Allow’ button, if exists, and then restart nxserver with /etc/NX/nxserver --restart. For more information:



Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.