NoMachine broken on Windows 10

Forum / NoMachine for Windows / NoMachine broken on Windows 10

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #33104

    Hi Guys,

    I am trying to install NoMachine on Windows 10 and the client is working fine, the server, not so much.

    When I try and install I get an error saying the nx user can’t be created (attached).

    I have no node.db file and when I try and restart from the command line I get the following.

    The system is

    I have attached nxdb




    Hi pnunn,

    We were not able to open the images in the topic thread and the nxdb file failed to attached.  Can you please send them directly to forum[at]nomachine[dot]com making sure you use the title of the topic in the subject of your email? Thanks!



    Hi Carin,

    Sent as requested.



    Hello pnunn

    Looks like you have a problem with creating a profile of user nx.
    There are 2 possible reason:

    1. Do you use domain users/LDAP/ActiveDirectory? Do you have non
    standard restrictions for users?

    2. It’s possible that default user profile on your host might be
    corrupted. You can try to create few user accounts and check if
    it’s possible to login on their desktops. If you experience any
    problems, please refer to this Stack Overflow thread:


    Thanks Zaq,

    This machine is a stand-alone Windows machine, no AD, no LDAP, not even a workgroup (everything else in the network uses a proper OS).

    Looks as though NoMachine is out then, I’m not creating new users just for this, unfortunately. Strange that nothing else I’ve installed has any issues that I know of.

    Thanks again.




    NoMachine server software needs nx user for its proper working. You can find more information here:

    If you just need to connect from the Windows machine to another computer you can install nomachine-enterprise-client package. It doesn’t need nx user:

    To investigate the problem please pack a folder with logs:


    and send to forum[at]nomachine[dot]com.


    Logs received. Thanks. The problem is directly related to this command:

    net user nx “PASSWORD” /y /ADD

    Could you:

    1) Open cmd as Administrator – open Menu Start and just write cmd, then choose ‘Run as administrator’.

    2) Run this command:

    net user nx "YOUR_PASSWORD" /y /ADD

    3) Send the whole output from the command to forum[at]nomachine[dot]com please?


    I ran the command as directed… no output at all.

    Just returned to the command prompt.


    You should get an output like:

    “The command completed successfully.”

    Looks like something is wrong with creating user accounts on your system.

    Could you check if user nx is present in a list of all of your users:

    net user

    if there is an nx user, please remove it by:

    net user nx /DEL

    We need to check system logs related to user management. You can enable it by:

    1. Click ‘Start’.
    2. Find Administrative Tools
    3. Open Local Security Policy
    4. Go to Audit Policy
    6. Enable AuditAccountManagement for Success and Failure:

    Click right button of the mouse on ‘Audit account management, go to Properties -> Audit these attempts,
    enable Success and Failure.

    After that you can check the logs:

    1. Go back to Administrative Tools.
    2. Open Event Viewer
    3. Go to: Windows Logs -> Security
    4. Create again the account:

    net user nx "YOUR_PASSWORD" /y /ADD

    5. In Event Viewer window click Action->Refresh, check logs related to creating user nx account, They have
    ‘User Account Management’ type in Task Category column.

    After that, you can disable system logs related to user management by restoring to original values AuditAccountManagement Policy.


    OK, have done that, and still no joy.

    There are masses of messages in the eventviewer related to user management, I’m not sure what ones are important.

    When I try and create the account, I get nothing in the logs.

    When I list the accounts, I can see all of the accounts being enumerated.

    That’s it.

    Still no output from the account creation.


    It’s strange because you mentioned that your other Windows computer installed fine.

    There’s not much we can do as it seems the default profile of your Windows host prevents our installation from creating user nx (without it NoMachine cannot function), and the only way to check whether your profile is corrupt in some way is by creating a new one and trying to install NoMachine in that.


Viewing 11 posts - 1 through 11 (of 11 total)

This topic was marked as solved, you can't post.