NoMachine connection fails first attempt, second attempt always successful

Forum / NoMachine for Windows / NoMachine connection fails first attempt, second attempt always successful

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #30307

    I think the issue is related to the remote machine’s Power & Sleep setting.

    The remote PC Screen is set to turn off after 3 hours.
    If it has been 3 hours and the screen is off when I connect, NoMachine displays the desktop, but mouse and keyboard input do not respond.
    After closing NoMachine and reconnecting, mouse and keyboard inputs work as expected.

    Remote & local OS: Windows 10
    NoMachine Version: 6.12.3 free version
    Connecting to a physical display on remote machine (3 displays are connected)


    We haven’t been able to reproduce this at all. Please send us a screenshot from the Advanced Power Settings plus logs from the affected Windows server host. Please see here for instructions on where to find logs.

    Submit everything to forum[at]nomachine[dot]com making sure to use the title of this topic as the subject of your email. Thanks!


    I have submitted the log files as requested.
    And, I made a video of all the Advanced Power Settings and sent that in an email too.

    Here is some more info on this behavior:

    1. When connecting the first time, I *DO* have mouse and keyboard control of the remote (server) PC, but I cannot see it.  I only see a static image of the remote desktop.  When double click on a desktop icon, nothing happens locally.  But, when I quit NoMachine and connect the second time, the program that I double clicked on is open and running.
    2. On the local machine, when I connect the first time, I see the remote (server) PC desktop, but when I move the mouse, the remote (server) mouse seems to just drift and not follow my local mouse cursor.  (I have show server mouse icon enabled).
    3. The remote (server) PC has 3 screens attached.
    4. The remote (server) PC is configured to login to a standard user (non-admin) account automatically at boot.  This is set by running the netplwiz utility:
      Then, in the User Accounts dialog box, click the account you want to automatically log on to.
      Then, clear the ‘Users Must Enter A User Name And Password To Use This Computer’ check box.
      Then, Click OK

    Hope that helps.  Thanks!


    Another user that remotes into the same PC is on Mac and also sees the same issue when first connecting.


    Any more progress looking into this issue?

    Anything more info or details you want from me?


    We haven’t been able to reproduce the problem unfortunately (although we are still trying). We are currently making some changes to initialization of desktop duplication which we use for capturing screen, and we think this will help your case when these get released, most likely in version 7 onwards.


    Thanks.  Any idea when I can expect to see version 7?


    Hi arlinsandbulte,

    I don’t have a date, but the release of version 7 should happen in the very near future.


    Update with version 7:

    Version 7 seems to have improved things.  I don’t see this issue every time anymore, but I do still see the same issue.

    So, it seems more random now.
    Sometimes first connection when the PC screen is sleeping, NoMachine works fine.
    Other times, same thing happens and I need to disconnect and reconnect.  After reconnecting, all works great.

    So, that is an improvement.  But, it might be harder to debug now because the issue seems more random.
    On version 6, it happened every time the remote PC’s screen timeout had been reached and the screen was sleeping.


    If you can send us logs when it does happen, this would be useful.

    Edit: the topic is now closed. If it happens again, please start a new topic.

Viewing 10 posts - 1 through 10 (of 10 total)

This topic was marked as solved, you can't post.