NoMachine connects but doesn’t accept keyboard or mouse input

Forum / NoMachine for Windows / NoMachine connects but doesn’t accept keyboard or mouse input

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1099


    I have installed NoMachine on my work computer (the remote) and the same version on my home computer (local).  I can make a connection to a remote machine with NoMachine but it shows me the login screen of the remote computer and will not accept keyboard or mouse input.  My setup is as follows:

    Remote Machine:

    • Windows 7 64 bit physical desktop
    • NoMachine 4.0.366_5 (free version)

    Local Machine:

    • Windows 7 64 bit virtual machine running on VirtualBox on Linux Mint 15
    • NoMachine 4.0.366_5 (free version)

    Another Local Machine:

    • Macbook Air OSX 10.9
    • NoMachine 4.0.366_1 (free version)

    I connect to my work office via VPN connection on a SonicWALL appliance at the office so the local machines and remote machines appear on the same network.  Locally, I am going through a DLink DIR-615 wireless router, however, the local Windows machine is a wired connection to the router (the MacBook connection is wireless).  Both the local Windows machine and the local MacBook exhibit the same symptoms: they connect and display the login screen of the remote computer but I cannot type, or click with the mouse.

    I have examined the logs on the SonicWALL and on the Dlink and can see no rejections of any kind.  I turned off the Windows firewall on the remote machine but that made no difference.

    Setting aside the VPN connection, I tried making a connection from the MacBook to the Windows machine on the local network.  It failed intermittently giving me by turns, a timeout error, a rejected by the server error and an I/O error.  When I turned off the Windows firewall on the local machine it seemed to connect, but the connection was really, really slow.  I mean really slow, like 10 seconds to respond to a mouse click.

    I feel like there is a configuration setting somewhere that I need to set but I can’t figure out what it is.  I have searched the forums, the documentation and the Internet with no luck.

    Can anyone help me?





    We’re investigating and will update with our findings. In the meantime can you tell us if you encountered the problem of input not being accepted anywhere else, e.g. is it only ever in the login screen?


    Since I can’t get beyond the login screen, I have no way of knowing.  However, on the one time that I made a successful connection between the Mac and the PC on the local network (which was really, really, slow) I was able to type.


    When I turned off the Windows firewall on the local machine it seemed to connect, but the connection was really, really slow.

    You said that it reports different errors when the connection fails. If the connection is blocked by the firewall it should always fail with “connection timeout” or, less commonly, with a “I/O error”, if the firewall is accepting and then closing the connection, but always in the same way. Please confirm that this is the case. Also: either the firewall is off or it is on. If it is on and NoMachine can connect, I presume the firewall is not working very well, that may be unlikely. NoMachine, at setup, opens the ports it is using on the firewall. Either opening the ports worked or not worked. I don’t think the firewall can let the connection succeed at random. But it can be that all connection succeeded, and later the sessions failed for some other NoMachine problem. In this case the firewall is not the culprit.

    About the slowness, it can be caused by the use of UDP on a extremely congested network or the VPN software slowing down UDP to prioritize other traffic. Are you connecting the two machines using the VPN? Try to disable UDP going in the connection settings, Edit -> Advanced -> set “Use UDP” off. Also, be sure the machine can connect and the connection works fine on the LAN before adding the VPN to the game.

    Since I can’t get beyond the login screen, I have no way of knowing.

    You can log in on the physical screen, then connect later, after you have gone past the login.

    We were able to reproduce this input bug in the login screen. There is another important bug having to do with Active Directory accounts. We hope to be able to release both fixes shortly.


    I’ve the same problem here. I use the free version 4.0.366 – amd64 on 2 Linux machines. One is running with Debian/Jessie and the other with Kubuntu 12.04. The Debian machine is my server and I connect from Kubuntu to Debian over the Internet. It connects and I get the login screen. Even the mouse pointer changes to the look of the one on the remote machine, but it takes no keyboard nor any mouse click.

    I tried the configuration switch “grab the keyboard input” and “show remote cursor pointer”, but this doesn’t change anything. I also tried to disable the firewall for a test, but no change.


    Problem found and fixed ;-). Hold on, guys. We are collecting more fixes and testing everything. The new build should be out before tonight. Don’t forget to use the automatic updates to get the changes and let us know if everything worked ;-). This is another important feature we are keeping in Beta state until we get enough reports.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.