NoMachine connects but then immediately disconnects

Forum / NoMachine for Windows / NoMachine connects but then immediately disconnects

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #46885

    Dear all,

    I have a problem on one PC out of 4: NoMachine correctly connect to the server and after showing the screen for 1 second correctly, closes itself. No error is given. The window disappear and I am send back to the main page of possible connections again. Repeating the process produce the same result. Whatever server I connect (3 different servers) the same happen.

    I know that the problem is on this PC and on client side: connecting between the other 3 PC, among them, all work correctly and connection is maintained. I can also connect to one of these PC and from there, connect to the third one by opening NoMachine remotely and all works well.

    All PC are updated to 8.11.3

    Before all worked flawless: in the meantime I did an update of my AMD catalyst graphic drivers on this PC (version 24.1.1) and the update of NoMachine.

    I have tried to uninstall NoMachine on this PC and revert back to version 8.10.1 but also this did not help.

    Seeking for a solution.

    Thank you,


    Sounds like a video driver issue, something in the update you said you just did. Can you try disabling hardware decoding in NoMachine on the client side (the machine you are connecting from)?

    First exit the Player on the machine you are connecting from by right clicking on the !M icon in the sytem tray and clicking Exit Player.

    Edit %USERPROFILE%\.nx\config\player.cfg and set:

    <option key=”Enable hardware accelerated decoding” value=”false” />

    Then create a new session and check if you still have the same issue.

    If you do, set the same key to:

    <option key=”Enable hardware accelerated decoding” value=”disabled” />

    and create a new session. The first setting disables the use of HW decoding but the codec library is still loaded, while the second settings disables completely the HW decoding. Let us know the results.


    Thank you for the support.

    Tried what suggested but with no effects.

    After this, I tried to put on compatibility mode (Win8) to the NoMachine’s exe and this did not even allow the start of the software. Then, I clicked compatibility mode off and ticked execution as administrator. Do not ask me why, but this did it!

    Problem for now solved.

    Thank you all!


    Dear all,

    unfortunately the problem come up again.

    All worked fine for weeks so I think it is not a problem of software/hardware but of handeling the number of connections when disconnecting.

    The error this time was triggered by the following:

    1. I opened client on a server 1

    2. Meanwhile I opened client on a server 2

    3. By mistake, I closed server 1 window.

    4. Server 2 in meantime closes because “he reached the maximum allowed connections”

    5. Tried to open client on server 1, connect for 1 second and then closes

    6. Tried to open client on server 2, connect for 1 second and then closes

    The previous solution (execution as administrator) I reported before do not solve the issue this time.

    Thank you.


    Dear all,

    some more details:

    – tried to restart the PC, still having the same behaviour

    – trying to connect from another PC (laptop) on server 1 or server 2 succeed without problems (same network); thinking therefore about some IP handeling restriction

    – i have tried to connect the PC to wifi disconnecting LAN used previously. Same behaviour, thus some IP handeling appears not to be the culprit.

    Tried reinstall, compatibility modes with no success.

    At this point I am out of options.

    It is possible to access some logs (client side or server side) to check out why these disconnection happen?

    Thank you.




    Dear all,

    sorry for the multiple posts. Got a solution again.

    Based on another post where it is suggested to: “If not, please try disabling hardware decoding in the NoMachine Windows client configuration.

    You can disable it completely in the player.cfg. Please edit the file $HOME/.nx/config/player.cfg and set the configuration key “Enable hardware accelerated decoding” to “disabled”. Before changing the configuration key, you should first quit the NoMachine Player (you can do this by right clicking on the !M icon in the system tray and selecting ‘Quit NoMachine Player’.”

    I did follow the guidelines with the only difference to set the flag to “false”. Now everything is working. Probably a problem with the GPU driver (ATI Catalyst) when connecting/disconnecting fast.

    If I can suggest an improvement, it might be a good idea to have on client configuration the possibility to enable an option that will ask confirm exiting the client windows by pressing the X on top right. The problem is that the client windows will all display their closing button in the same spot so that a misclick on the X of the client windows is possible even if you wanted only to close the windows displayed on server side. A warning may be helpful.

    Thank you.


    Hi, if the issue happens again, we would like to see the nxtrace. The nxtrace.log file is generated only in case of a sudden termination of any of the NoMachine programs. It’s stored in: %PROGRAMDATA%/NoMachine/var/log on Windows Vista, 7, 8, 8.1, 10. I’ve passed your suggestion on to the developers 🙂


Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.