NoMachine default install fails on Windows 11

Forum / NoMachine for Windows / NoMachine default install fails on Windows 11

Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #43502

    Processor    AMD Ryzen 5 3600X 6-Core Processor                3.80 GHz
    Installed RAM    32.0 GB
    System type    64-bit operating system, x64-based processor

    Edition    Windows 11 Home
    Version    22H2
    Installed on    ‎3/‎7/‎2023
    OS build    22621.1413
    Experience    Windows Feature Experience Pack 1000.22639.1000.0

    I just freshly installed Windows 11, and when I tried to install nomachine_8.4.2_10_x64 straight form the official downloads page (with matching hash), I got a bunch of errors during the install process saying DLLs were missing, then it told me to restart to complete the installation. Well, the system icon tray never appears, launching the NoMachine client is very slow, and I can’t share my desktop. I tried right clicking the installer and running as admin just as a test, and the missing DLL errors did not appear, but the end behavior is still the same: slow, no system tray icon, can’t share desktop. Checking for updates also fails.

    I can, however, successfully connect to other NoMachine servers on my network.

    I’m attaching some logs as a zip file from the normal (not manually running as admin) install, looks like there are some errors in there.

    Can anyone assist?



    This looks like an issue we already discovered when Firefox is in use.
    The described behaviour is strictly related to how Firefox handles
    the executable, in particular we found that it sets the ‘PreferSystem32Images’
    flag before running the .exe application.

    Do you use Firefox to directly run installation? Here is a related article:

    and here you can track fixing the bug by Mozilla:


    I did download the installer via firefox, but I launched it using Explorer, not the firefox download manager.

    I uninstalled and then reinstalled using chocolatey, and it appears to work fine now. So it may indeed have had something to do with firefox.


Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.