NoMachine for Fedora 36

Forum / NoMachine for Linux / NoMachine for Fedora 36

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #39668

    Hi. I want to install NoMachine on my laptop with Fedora 36 OS so I download RPM from here next I try to install it by sudo rpm -i nomachine_7.10.1_1_x86_64.rpm but it gives me errors:
    NX> 701 Creating configuration in: /usr/NX/etc/server.cfg.
    NX> 701 ERROR: Installation of NoMachine server is corrupted:
    NX> 701 ERROR: Missing /usr/NX/etc/keys/node.localhost.id_dsa ssh key file!
    NX> 701 ERROR: Please uninstall and install the package again.
    NX> 701 Bye.

    I tried reinstalling it but when i run sudo rpm -e nomachine it only informs “not found /etc/NX” and installing again in vain. I have Fedora 36, CPU Intel i5, uname -p gives x86_64 so where is the problem? Is it possible to install NoMachine at Fedora 36?


    We have no issues installing on Fedora 36.

    Did you install over having previously installed/uninstalled another NoMachine product?

    Try uninstalling cleanly with

    sudo rpm -e nomachine
    sudo rm -rf /usr/NX /etc/NX

    and install again.


    Right, Your fast and easy advice resolved my problem. But here is one more, maybe small question: installation of NoMachine gave me this info:

    PulseAudio Backend

    The NoMachine  setup procedure  could not  detect  your  PulseAudio
    installation:  either  PulseAudio is not  installed  on your system
    or it was  installed  in a non-standard path.  If PulseAudio is not
    available, NoMachine audio support will try to rely on ALSA device.
    Please note  that you can enable  PulseAudio  support  at any time;
    to do this  make sure that you have PulseAudio installed, then run:

    /usr/NX/scripts/setup/nxnode --audiosetup <path>

    but dnf list installed informed me I have this:

    pulseaudio-libs.x86_64                      15.0-5.fc36                @fedora
    pulseaudio-libs-glib2.x86_64                15.0-5.fc36                @fedora
    pulseaudio-utils.x86_64                     15.0-5.fc36                @fedora

    so is everything OK? Do I have lack of packages? Should I repair anything (what and how)?

    Thank you again.


    The output shows that PulseAudio libs are present but not that PulseAudio is installed and being used. Fedora 36 now adopts Pipewire instead of PulseAudio and it is likely that it is using those libraries.


    Support for Pipewire in NoMachine will be added in v8.

    So first install PulseAudio:

    sudo dnf install pulseaudio

    Fedora will ask you to remove Pipewire and replace it with PulseAudio. Then you can install NoMachine again or use command from installation output:

    /usr/NX/scripts/setup/nxnode --audiosetup <path>

    to configure PulseAudio with NoMachine.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.