NoMachine for Mac does not install USB kext

Forum / NoMachine for Mac / NoMachine for Mac does not install USB kext

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #37715

    Hi everyone,

    I’m facing the exact issue described in .

    The blog says that it was resolved, however even after downloading and installing the latest version (7.8.2_4), it still is not installing any USB kext drivers.

    System info:
    MacOS 12.0.1
    NoMachine 7.8.2

    product: Server, free

    Attached – directory listing of  /Library/Application Support/NoMachine/Extensions (no USB kext drivers here)

    What I’ve already tried :

    - uninstalling/reinstalling multiple times

    - sudo kextstat | grep nx

    (Didn’t show any USB related drivers because they aren’t present in the first place)

    On this thread, there is a mention of a script that was circulated to help people overcome this issue. I would appreciate it if that could be sent to me on DM or could be put here as an attachment to assist anyone else stuck in the same issue.





    since NoMachine 7.8.2 update kext drivers are no longer needed on MacOS 12 and USB service should be working without it.

    If you encounter problems with forwarding USB devices, you may try to restart your machine and make sure all the permissions required by NoMachine are granted in the “Security & Privacy” settings.



    Hi Dawid,

    I had already given access to NoMachine s.a.r.l. in th “Security & Privacy” Settings much earlier without any luck, and have tried restarting the machine and trying to share my local device, but all with the same error ‘Failed to connect the device <device name>’

    Is there any way I can check and confirm if NoMachine server has sufficient permissions and if that is the issue?

    For more info, I am trying to connect to a remote dedicated server that I have taken up on MacInCloud, and I have attached a screenshot of the ‘Connect a USB Device’ section in my local nomachine instance. Apparently, if USB is working correctly on the remote server in macInCloud, you are supposed to see a bunch of VMs as well in the remote USB devices (as you can see here – )


    unfortunately, we weren’t able to reproduce your issue. Please send us the output of this command from your MacInCloud machine while trying to share a USB device:

    sudo launchctl list | grep nxusb

    We would also appreciate it if you would send us NoMachine client and server logs via email using this guide (forum[at]nomachine[dot]com:



    Just posting here since I’m new to NoMachine but this issue is really confusing when searching the net

    I was trying to connect a phone on my physical machine(windows 10) an tunnel the USB connection to a remote one (ios). Things just didn’t work so I tried different solutions regarding usb transmission over the net. By luck I found Flexihub, which complained about the fact I had “USB Network Gate” installed. Well, I unistalled USB Network gate, flexihub didn’t work due subscription issues so I went back to NoMachine a second time and things worked fine.

    I really believe USB network gate was the problem, it was installed by a colleague and was a pain to uninstall.

    So my 5 cents: Give a check for USB Network Gate or any other USB over ethernet solutions you have installed since they have a way to hide themselves out of the usual application folder in mac, uninstall them and try again.


    Thanks for posting that.

    We have an article that would be useful in this case:

    How to handle possible conflicts between NoMachine USB module and third party drivers

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.