NoMachine from Windows 10 to Mac Yosemite 10.5.5 will not go fullscreen

Forum / NoMachine for Windows / NoMachine from Windows 10 to Mac Yosemite 10.5.5 will not go fullscreen

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #8176

    I am connecting from NoMachine (4.6.16) on Windows 10 to a Mac mini running Yosemite 10.10.5. I cannot get the display to go full screen (2560×1440).

    Two hours ago, my Mac mini was the previous version of OSX, so maybe 10.9.*, and I was able to go full screen just fine. Nothing has changed with my setup/configuration, with the exception of the upgrade from OSX 10.9.* to 10.10.5.

    I have tried to adjust the display settings here,, but nothing seems to be working. When I do display = Fullscreen, NoMachine occupies the entire screen (2560×1440), but my Mac OSX is not the entire screen as a black border surrounds much of it. When I then click on Fit to window, NoMachine changes the remote desktop resolution to be stretched, which is not ideal because it looks terrible, since before I upgraded my Mac OSX OS to 10.10.5, this was working fine and a full screen looked great (not stretched). I guess I want to have my cake and eat it too.

    Is my scenario supported? Connecting from NoMachine 4.6.16 on Windows 10 to Mac OSX 10.10.5 with a Windows screen resolution of 2560×1440?

    Thanks for any help.



    Hi Mule52,

    supported resolutions don’t depend on the NoMachine software, but on what is supported on the remote system. In other words, the 2560×1440 screen resolution will be available in your NoMachine session only if such resolution is selectable in the system settings of your remote Mac.

    If that resolution is among the available ones on your Mac, then you may simply need to click on the “Resize remote screen” button (the one on the right of “Fit to window”). That will make the remote screen automatically resize to the resolution that will fit better in your local screen.


    If my scenario described in the original post cannot be achieved via NoMachine, then I may have the same issue described here, I went ahead and ordered a fit-headless-4k dongle to see if that works,

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.