NoMachine is not responding

Forum / NoMachine for Windows / NoMachine is not responding

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #8395

    I don’t understand why, when I launch NoMachine on my Windows 7 desktop to connect to my Windows server (with NoMachine 4.6.16 version on both), I can log into my account (so the client can see the server) I put the password and then :

    • the NoMachine window freezes, no responding
    • the pointer goes on turning around ;
    • and if I click on the window again, it turns in grey

    No other choice than closing the unresponding program.

    Any help please ?

    (sorry if my English isn’t always correct.)


    Can you update to version 5? If the problem is still there, let us know.


    I see the same issue and both my client and server are running a recent build from a few days. See my most recent post in the thread I started a couple days ago.


    Thank you Britgirl for your help.

    I’ve updated NoMachine on the client at the first time and it was ok for a moment.

    Then my connection always shut down or tend to get lost. It’s probably due to my network.

    By the way, I updated the software on the server to avoid the misunderstandings.

    Now I can’t connect anymore and get the message “No message data. Error n°146”.

    What does that mean ?

    I’ve already got that message by the past, but don’t know how I solved it. (maybe reinstalled all).

    (For information; I manage to connect in the other side. And I can either use vnc protocol to connect  but would I prefer NoMachine because the display is usually faster more nice !).

    I’ve made two snapshots to illustrate.



    I wanted to add that on the server the connection is done during few seconds because there is the notification sound and little box.


    Hi Motto.
    The problem you’re reproducing on version 5 may not be the same you had on version 4, we would need some logs to understand what is happening. Could you please retrieve them?
    Get server logs as explained in, and client logs by clicking the button “Save logs/Enregistrer les journaux” in the error dialog. Compress all information and send them to forum[at]nomachine[dot]com. Thank you!


    Thank you Tor !

    I ‘ve send you the logs you claimed.

    Thank you for your help !


    Hey motto, this is just to tell you that we’re still checking the problem. I’ll let you know something as soon as possible.


    Hi Tor,

    I’ve just retrieved the NoMachine use !! :-)) I don’t know how, once again !

    What I’ve done is to reinstall the NoMachine software on the client computer version 5.0.47 up-to-date.

    This morning I restart my server machine for other purpose and try the NoMachine to test my luck !!!

    And here it is !! All is working fine ! What else ?

    So I expect the logs I sent you will help discover something to improve the NoMachine software.

    Thank you for your support.





    Hi Tor and everybody !

    My NoMachine gives me the same n°146 message error,  every time I disconnect from the server or quit the player !

    I must restart the computer server each time !

    1. Did you find anything about that issue ?

    On the other hand, I notice that on the server, when I launch NoMachine client or services, the soft can’t manage to get Public IP Address but only Private IP.

    2. I don’t know if it could give you a hint on what happens ?


    Hi motto.

    Our engineer didn’t find relevant information in your logs, he was planning to ask your help to test a new debugging version but you solved the issue and he became sad! Now that you’ve found a new way to reproduce it, I’m sure he’ll return to the fray. 🙂

    Can you please do the following when you reproduce the issue, and let me know if it is enough to work around it:

    – Open the NoMachine menu and select ‘Show the connection status’
    – Click the ‘On’ button to shut down the server
    – In the new dialog click ‘YES’ to restart the server at the next reboot
    – Authorize the server shutdown
    – Open the NoMachine Client
    – Click the ‘Settings’ button
    – Click the ‘Connection status’ link
    – Click the ‘Off’ button to start the server
    – Authorize the server startup
    – Click the ‘Close’ button

    For the record, with the next release we’ll offer an easier way to restart the server from the GUI. It is not a common operation for a user, but it may still be useful.


    Hi Tor,

    I try to reproduce yours commands instructions. It seems not to be enough to solve this issue.

    I have to restart the PC to make the connection work.

    The message error is “Connection lost”, most of the time now, instead of “no data message”.


    Hi Motto!

    Our engineer would like to send you some debugging libraries to retrieve more information. Can you please confirm the NoMachine version you’re using on client and server? We’ll contact you by e-mail. Thanks.


    This has been open for some time and we have not heard back. Please download and install (or use the automatic updates) the latest version and let us know if you are still encountering the problem. Thanks!

Viewing 14 posts - 1 through 14 (of 14 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.