NoMachine issue with Ubuntu 18.04

Forum / NoMachine for Linux / NoMachine issue with Ubuntu 18.04


Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #26931

    Hello to everyone

    We are trying to use NoMachine to remote to few physical Workstation but we are having some issue when we try to connect to Ubuntu 18.04.

    When some user has some issue most of the time it works restarting the services sudo /etc/NX/nxserver –status ( but not always sometimes we needed also a reboot of the system

    One of the issue we have is a white screen after after connection. I read a post to uncomment the line
    on the Configuration file /etc/gdm3/custom.conf  and restart gdm3

    but from what i have understood this issue is related only for Virtual Machine while we are working in Physical Machine.

    2. Another issue is similar to that, a user can login but he cannot interact with his session.

    It is possible that some previous connection remains hanging preventing a new connection? W can tune some known Ubuntu Configuration or issue?


    Hello, please look at session logs in folders /usr/NX/var/log/node/… That would help to identify the source of the problem.


    Thanks for you reply I started to look under that folder but now i need to understand what to look for

    There are some folder where i’m the owner but some others as gdm as owner.  Basically i have 5 subfolder under the path in two i’m the owner and the other are owned by gdm.

    • one name folder start with C-hostname-1001-…..
    • the rest of the others folders is named with F-C-hostname-1001-….

    This five folder correspond to five issue?  Within the folders i need to check the session file for the errors?



    For the white screen on physical desktop. Does the reboot / NoMachine restart you mention fix this? If yes there could be something interfering with the ability to
    detect or mirror the display. It may be something running in the background – like virtual frame buffer – or the Wayland itself can cause troubles. Generally the
    white screen on Wayland is connected with virtual machines or proprietary drivers, but it may happen in other circumstances. As graywolf wrote the reason should be
    in the logs. You can find them in “session” files inside the /usr/NX/var/log/node/C-* directories. If having troubles please send them to us for investigation.

    As for issue 2. Does it also happen on attach to physical desktop? Or is it virtual? Both of the issues may be connected, but there is also additional possibility.
    Please check the server.cfg file and search for keys PhysicalDesktopMode and VirtualDesktopMode if they are uncommented and set to 0 this may be the cause.

    It is possible that both of this issues are Wayland related so if it is possible, please check if there is any change in behavior when setting WaylandEnable=False.

    In case you are willing to provide us with full logs, the article on how to collect logs: (“How to gather debug logs for support requests”)

    Please enable the debug and then do

    /etc/NX/nxserver --restart

    And then please reproduce the white screen and/or interaction problems.

    Afterwards you can use the command

    /etc/NX/nxserver --debug --collect

    for NoMachine to automatically collect and pack the logs, or do it manually.

    Please send the logs to forum[at]nomachine[dot]com using the title of that forum’s thread as the mail’s subject.



    First thanks to all

    Yes after a reboot  it works,  sometimes i just need to restart the service and kill all the process but if i disconnect and reconnect most of the time i have the white screen, not always but often.

    • PhysicalDesktopMode and VirtualDesktopMode are both commented in the server.cfg
    • I have also tried to uncomment the wayland=false on the  /etc/gdm3/custom.conf and the I have restarted gdm3 services, the result it is not a white page but it not working fine. Maybe I need restart?

    In One of the session log, the one owned by gdm I found this error:

    Info: Agent running with pid 7343.

    Info: Slave server running with pid 7355.

    Info: Display running with pid 7356.

    Info: Listening to slave connections on port 12001.

    Info: Audio server started with pid 7369.

    Info: Audio client started with pid 7370.

    Info: Display server started with pid 7371.

    Session: Session started at Wed Apr 22 17:51:28 2020.

    7343 7356 17:52:01 331.448 DrmGrabber: ERROR! Failed to get fb info.

    7343 7356 17:52:01 331.470 DrmGrabber: ERROR! FbInfo init failed.

    7343 7356 17:52:01 331.474 WaylandPoller: Init failed.

    7343 7356 17:52:01 332.324 WaylandPoller: WARNING! Failed to restore screen info without having DBus connection.

    nxagentShadowInit: ERROR! Failed to initialize the shadow display.

    Info: RT handler running with pid 7523.

    Info: Display server for 3162E3853F7D555722428812693C4E0C connected on Wed Apr 22 17:52:01 2020.

    Info: Audio server for 3162E3853F7D555722428812693C4E0C connected on Wed Apr 22 17:52:01 2020.

    Info: Audio client for 3162E3853F7D555722428812693C4E0C connected on Wed Apr 22 17:52:01 2020.

    Info: Audio reader running with pid 7556.


    Just for info the Video Diver is an Intel i915 I need to remove the driver enabling nouveau?




    Using nouveau would make sense if you had an Nvidia card. Intel driver usually has not any problem.

    After you changed /etc/gdm3/custom.conf, restarting could help.

    Would you tell me the kernel version and the video card information? Commands uname -r and lshw -C display would dump that info.


    For the moment i’ve tried to update Ubuntu ed I’m testing now if it works with some stability or not. If it is not stable I will uncomment   WaylandEnable=False and I will reboot the system, previously i restarted only the gdm service:

    I run the command you told me below the result:

    Kernel Used:  4.15.0-96-generic

    lshw -C display:


    description: VGA compatible controller

    product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller

    vendor: Intel Corporation

    physical id: 2

    bus info: pci@0000:00:02.0

    version: 06

    width: 64 bits

    clock: 33MHz

    capabilities: msi pm vga_controller bus_master cap_list rom

    configuration: driver=i915 latency=0

    resources: irq:32 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64) memory:c0000-dffff


    Thanks! I will give update after few test



    It seems to be better but now the user seems to have duplicated Icon over the desktop


    All the icons? Is it Gnome or KDE?


    It is Standard Ubuntu 18.04 Gnome. Today I have uncommented the line WaylandEnable=False and I have rebooted the system.

    It works fine for me, I tried few times and I didn’t have any problems but not for the user that have to work remotely.

    He connect to the login screen of Ubuntu but it didn’t appear any login name or a box where to login and if it click on the screen  he become black.



    Would you collect logs:

    1. Enable with /etc/NX/nxserver –debug –enable
    2. Replicate the issue
    3. Collect with /etc/NX/nxserver –debug –collect
    4. Send log archive to forum (at) nomachine (dot) com



    Thanks again

    I will try to collect but I don’t know if I can sent depends on the information he collects. There are data that I cannot share, username, ip address…

    However is very strange.

    We are remoting to the same Physical Ubuntu 18.04  from a Virtual Windows 2012 remote server that is used as Remote Desktop Gateway.

    Basically we connect via rdp to Windows and within Windows we run NoMachine.

    I don’t have any problems with my session, while he has problems with his session. We remote to the same physical Ubuntu Workstation from a Windows 2012 that for sure has the same configuration. Basically it is the same VM for everyone.

    I don’t know if the user did something who can breaks the configuration, however it worked smoothly at the beginning and now there isn’t way to make it work at least at least for him. It worked also before I modified the WayLand configuration.

    Maybe reinstalling NoMachine in the Ubuntu Ws can solve?




    I think is the session with problems affecting my collegue: (attachment)


    I see nothing bad in the log. From what you told me, it could be something different in the clients running on the Windows terminal server. So I’d try to remove NoMachine client on Windows server, then move %USERPROFILE%\.nx elsewhere, and finally re-install NoMachine client.

Viewing 14 posts - 1 through 14 (of 14 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.