NoMachine mouse only moves down/right when interacting with virtual machines

Forum / NoMachine for Mac / NoMachine mouse only moves down/right when interacting with virtual machines

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #40696

    This is a little weird, so I will try to describe as many details as I can.

    I have a MacBook Pro with NoMachine 7.10.1 sharing my desktop.  I can connect to the notebook over my network from my Windows desktop with NoMachine 7.10.2, everything works as expected.  I use my notebook to virtualize various environments for retro-computing purposes, specifically I keep a Windows 98 VM (running in vmWare Fusion) and a Mac OS 9 VM (running in Qemu).  If I launch either of the virtual machines and try to interact with them the mouse will only move downward and to the right in the VM (+1 to X and +1 to Y regardless of the movement of the actual mouse).  This happens in both Fusion and Qemu but ONLY when I use NoMachine to connect to the MacBook host.  If I interact with the VMs directly on the Notebook, the mouse tracks correctly.  Even weirder, if I depress the left mouse button the mouse will begin to track correctly until I release the mouse.

    To attempt to summarize:

    Windows Desktop connected to MacBook Pro Notebook with NoMachine, then launching a VM on the MacBook Pro causes the mouse to be uncontrollable inside the VM.

    I tried to capture the problem with a short video you can view here.

    The first thing I went looking for were options in Fusion/Qemu and NoMachine that tinker with the mouse, but I haven’t been able to affect the problem in any way.  I would love if someone more knowledgeable about tweaking NoMachine could give me some ideas to try.




    please try to add the following key in the /Applications/ file on the server machine:

    DisplayServerExtraOptions "-oldeventapi 1"

    Restart NoMachine and see if anything changes.


    Thanks for the suggestion.  Unfortunately, my MacBook Pro is giving me some serious (unrelated) problems, and I am unable to try this to see helps.  If (by some miracle) I get myself back on Terra Firma, I will give this a go.  Thanks again!

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.